Bug 177535 - libnotify should have a Requires: notify-daemon
libnotify should have a Requires: notify-daemon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-01-11 12:13 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 15:49:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-01-11 12:13:10 EST
Description of problem:
Applications using libnotify expect something user-visible to happen if they use
the libnotify API; if notify-daemon is not installed the notifications will fail.

Suggest that libnotify should have a "Requires: notify-daemon" so that
applications using notifications can simply "Requires: libnotify" in order to
have it work sanely.

Version-Release number of selected component (if applicable):
libnotify-0.3.0-2
Comment 1 Ray Strode [halfline] 2006-01-11 14:26:37 EST
Adding to caillon's stack
Comment 2 Christopher Aillon 2006-01-11 23:34:02 EST
Not sure if we should actually add this Requires since technically libnotify
doesn't rely on a specific notification daemon, but we should make sure that
notify-daemon is in comps to everwhere libnotify is...
Comment 3 Dave Malcolm 2006-01-12 11:36:10 EST
Perhaps could address that with a virtual Provides/Requires in
notify-daemon/libnotify respectively.

I've added a manual Requires: notify-daemon to evolution-2.5.4-4 since evolution
expects a notification daemon to be running; I still think it makes sense to do
this at the libnotify level, rather than adding it to every package that uses
libnotify.
Comment 4 Christopher Aillon 2006-01-12 11:39:49 EST
Yeah, I built a virtual provides earlier this morning.  It's
desktop-notification-daemon fwiw.  Evolution is currently building to remove the
hack.

Note You need to log in before you can comment on or make changes to this bug.