SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 1775379 - Clicking the Prometheus UI link does not open anything under the metrics menu. Missing HREF tag.
Summary: Clicking the Prometheus UI link does not open anything under the metrics menu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-21 20:09 UTC by okashi
Modified: 2020-03-02 15:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:13:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Where the link is located (44.03 KB, image/png)
2019-11-21 20:09 UTC, okashi
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3533 'None' closed Bug 1775379: Don't show Prometheus UI link when not discovered 2020-03-02 15:06:37 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:14:04 UTC

Description okashi 2019-11-21 20:09:54 UTC
Created attachment 1638572 [details]
Where the link is located

Description of problem: After clicking Monitoring > Metrics > Prometheus UI nothing happens.


Version-Release number of selected component (if applicable): 4.2.4


How reproducible: In the left menu click Monitoring > Metrics > Prometheus UI nothing happens.


Steps to Reproduce:
1. in the left menu click on Monitoring
2. click Metrics
3. click "Prometheus UI" on the metrics page that opens.

Actual results: Not Clickable.  Link seems to be missing HREF tag


Expected results: Open the Prometheus UI


Additional info:

Comment 2 shahan 2019-11-25 04:25:09 UTC
Sam,
  Since Prometheus was installed by default, how can i make the Prometheus route to be undiscovered for web console? I tried to remove Prometheus route and the link still show up on the monitoring page.

Comment 5 Yanping Zhang 2019-11-27 07:11:37 UTC
Thanks very much, @juzhao

Payload: 4.3.0-0.nightly-2019-11-26-171052
Check "Monitoring"->"Metrics" page on console, click "Prometheus UI" link, will open prometheus console correctly.
Do some modifies:
1.# oc -n openshift-cluster-version scale deploy cluster-version-operator --replicas=0
2.# oc -n openshift-monitoring scale deploy cluster-monitoring-operator --replicas=0
3.# oc -n openshift-monitoring edit cm  sharing-config
  Update "prometheusURL" as null.
4. Then check "Monitoring"->"Metrics" page. There is no "Prometheus UI" link shown now.
The bug has been fixed.

Comment 7 errata-xmlrpc 2020-01-23 11:13:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.