Bug 1775434 - reposync does not properly sync modules with --newest option
Summary: reposync does not properly sync modules with --newest option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf-plugins-core
Version: 8.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.0
Assignee: Jaroslav Mracek
QA Contact: swm-qe
URL:
Whiteboard:
: 1776410 1807830 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-21 23:29 UTC by Ryan Mullett
Modified: 2020-06-26 18:43 UTC (History)
13 users (show)

Fixed In Version: dnf-plugins-core-4.0.12-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:49:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 5186621 None None None 2020-06-26 18:43:30 UTC
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:17 UTC

Internal Links: 1833074

Description Ryan Mullett 2019-11-21 23:29:33 UTC
Description of problem:
When using reposync to sync a repo using the --newest option, modules that share a name, but have multiple streams only sync the most recent stream instead of syncing the newest package from both streams. As an example, the following are the available perl module streams:

perl                             5.24                     common [d], minimal                                  Practical Extraction and Report Language                                      

perl                             5.26 [d]                 common [d], minimal                                  Practical Extraction and Report Language                                      

If you use reposync with --newest on RHEL 8, you end up only syncing the 5.26 stream, and you don't get any packages from the 5.24 stream.

Version-Release number of selected component (if applicable):
yum-utils-4.0.8-3.el8.noarch

How reproducible:
Always

Steps to Reproduce:
1. # reposync --repoid=rhel-8-for-x86_64-appstream-rpms --newest

Actual results:
The reposync command only obtains the newest stream instead of the newest package from each stream

Expected results:
The reposync command should obtain the newest package from each stream, instead of only obtaining the newest stream

Additional info:
It should be noted, that even fixing this, modules will still be a bit odd with --newest. The reason being, that in order to have module metadata you'll have to reposync with the --download-metadata option still, and in that situation you'll have metadata for packages that you don't actually have downloaded. This shouldn't prove to cause any dependency issues in the resulting synced repo though as far as I can tell.

Comment 1 Jaroslav Mracek 2019-11-29 12:52:15 UTC
I create a patch (https://github.com/rpm-software-management/dnf-plugins-core/pull/375) that will download all latest non-modular packages plus all
packages for contexts with latest version for each module stream. The new behavior will be perfectly visible with perl and perl-DBI modules.

Comment 3 Jaroslav Mracek 2019-12-09 09:07:33 UTC
Is the new behavior according to customer needs?

Comment 4 Marek Blaha 2019-12-09 11:36:11 UTC
*** Bug 1776410 has been marked as a duplicate of this bug. ***

Comment 5 Ryan Mullett 2019-12-09 17:00:07 UTC
(In reply to Jaroslav Mracek from comment #3)
> Is the new behavior according to customer needs?

From what I see on the PR that appears to be exactly what is desired thanks!

Comment 12 Daniel Mach 2020-03-04 08:39:52 UTC
*** Bug 1807830 has been marked as a duplicate of this bug. ***

Comment 13 Vasil Velichkov 2020-03-20 22:31:46 UTC
Hi,

> Fixed In Version: dnf-plugins-core-4.0.12-2.el8

Do you have an ETA for this version? Is there any updates testing repository where this version could be downloaded from?

Comment 15 amatej 2020-04-22 11:16:52 UTC
The fixed package is part of RHEL 8.2, which according to the post https://www.redhat.com/en/about/press-releases/red-hat-delivers-force-multiplier-enterprise-it-enhanced-intelligent-monitoring-unveils-latest-version-red-hat-enterprise-linux-8 is now generally available.

It doesn't appear to be possible to download it quite yet, but should be soon.

Comment 18 errata-xmlrpc 2020-04-28 16:49:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.