Bug 177545 - Executes command on SIGHUP!
Summary: Executes command on SIGHUP!
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bash   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-01-11 18:12 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 3.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 10:37:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2006-01-11 18:12:46 UTC
Description of problem:
Executes command line when SIGHUP received.

Version-Release number of selected component (if applicable):
3.1-3

How reproducible:
100%

Steps to Reproduce:
1. Open gnome-terminal
2. 'rm -f /tmp/foo' and press Enter
3. 'touch /tmp/foo' but DON'T press Enter
4. Close window
5. Open new gnome-terminal window
6. 'ls /tmp/foo' and press Enter
  
Actual results:
/tmp/foo has been created

Expected results:
Shouldn't have been!

Additional info:
Possibly due to bash-sighandler.patch.

Comment 1 Tim Waugh 2006-01-12 10:37:35 UTC
Fixed in 3.1-4.


Note You need to log in before you can comment on or make changes to this bug.