Bug 1775454 - node-exporter "/var/node_exporter/textfile/virt.prom" file contains unescaped new-line
Summary: node-exporter "/var/node_exporter/textfile/virt.prom" file contains unescaped...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Paul Gier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-22 02:23 UTC by Junqi Zhao
Modified: 2020-05-04 11:16 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1777233 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift node_exporter pull 42 'None' closed Bug 1775454: virtwhat multiple platform 2020-06-15 06:11:12 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:16:54 UTC

Description Junqi Zhao 2019-11-22 02:23:24 UTC
Description of problem:
# oc -n openshift-monitoring logs -c node-exporter node-exporter-7lgft
time="2019-11-22T01:36:51Z" level=info msg="Starting node_exporter (version=0.18.1, branch=rhaos-4.3-rhel-7, revision=7cec12769a7eafb0c17e34bb940d7302b31104c4)" source="node_exporter.go:156"
time="2019-11-22T01:36:51Z" level=info msg="Build context (go=go1.12.12, user=root@87c64747e875, date=20191121-18:20:55)" source="node_exporter.go:157"
time="2019-11-22T01:36:51Z" level=info msg="Enabled collectors:" source="node_exporter.go:97"
time="2019-11-22T01:36:51Z" level=info msg=" - arp" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - bcache" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - bonding" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - conntrack" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - cpu" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - cpufreq" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - diskstats" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - edac" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - entropy" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - filefd" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - filesystem" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - hwmon" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - infiniband" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - ipvs" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - loadavg" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - mdadm" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - meminfo" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - mountstats" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - netclass" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - netdev" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - netstat" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - nfs" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - nfsd" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - pressure" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - sockstat" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - stat" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - textfile" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - time" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - timex" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - uname" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - vmstat" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - xfs" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg=" - zfs" source="node_exporter.go:104"
time="2019-11-22T01:36:51Z" level=info msg="Listening on 127.0.0.1:9100" source="node_exporter.go:170"
time="2019-11-22T01:44:50Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:45:02Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:45:20Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:45:32Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:45:50Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:46:02Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:46:20Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:46:32Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:46:50Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:47:02Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:47:20Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:47:32Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:47:50Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:48:02Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:48:20Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:48:32Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:48:50Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:49:02Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:49:20Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:49:32Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:49:50Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:50:02Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:50:20Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:50:32Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:50:50Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:51:02Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
time="2019-11-22T01:51:20Z" level=error msg="Error parsing \"/var/node_exporter/textfile/virt.prom\": text format parsing error in line 3: label value \"xen\" contains unescaped new-line" source="textfile.go:211"
************************
# oc -n openshift-monitoring exec  -c node-exporter node-exporter-7lgft -- cat /var/node_exporter/textfile/virt.prom
# HELP virt_platform reports one series per detected virtualization type. If no type is detected, the type is "none".
# TYPE virt_platform gauge
virt_platform{type="xen
xen-hvm"} 1


Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-21-230534

How reproducible:
always

Steps to Reproduce:
1. see the description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 errata-xmlrpc 2020-05-04 11:16:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.