Bug 1775471 - yaml editor does not work well after click shortcut popover
Summary: yaml editor does not work well after click shortcut popover
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1779383
TreeView+ depends on / blocked
 
Reported: 2019-11-22 03:45 UTC by shahan
Modified: 2020-05-04 11:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1779383 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3652 'None' closed Bug 1775471: Restore focus to YAML editor when hiding shortcuts popover 2020-04-17 17:13:56 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:16:54 UTC

Description shahan 2019-11-22 03:45:48 UTC
Description of problem:
Yaml editor does not work well after click shortcut popover

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-21-122827

How reproducible:
Always

Steps to Reproduce:
1. Click 'Import YAML' button on the meathead and inpuSortt some word
2. Then click the 'Shortcuts' on the top-right of  editor
3. trying to input some word again

Actual results:
3. The editor cannot input words anymore

Expected results:
It should works well 

Additional info:

Comment 1 Samuel Padgett 2019-11-22 14:14:03 UTC
This seems to only happen if you click outside the popover directly in the editor at the same spot which was previously focused. This is easy to reproduce when the editor is empty because you can't click anywhere in the editor. Closing the popover with the close button or escape key doesn't cause the issue.

Comment 3 shahan 2019-12-16 03:41:16 UTC
The focus can back to YAML editor after click shortcuts popover.
Verified this bug
4.4.0-0.nightly-2019-12-15-184910

Comment 6 errata-xmlrpc 2020-05-04 11:16:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.