Bug 1775542 - payload 4.2.8 need the signature
Summary: payload 4.2.8 need the signature
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2.z
Assignee: Luke Meyer
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-22 08:53 UTC by Jian Zhang
Modified: 2019-12-03 22:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 22:43:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3953 None None None 2019-12-03 22:43:23 UTC

Description Jian Zhang 2019-11-22 08:53:41 UTC
Description of problem:
Failed to upgrade to 4.2.8 from 4.2.7 since "the image may not be safe to use".
mac:~ jianzhang$ oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.7     True        True          97s     Unable to apply 4.2.8: the image may not be safe to use



Version-Release number of selected component (if applicable):
4.2.8

How reproducible:
always

Steps to Reproduce:
1. Install OCP 4.2.7
2. Upgrade it to 4.2.8.

Actual results:
Failed to upgrade. See screenshot: https://user-images.githubusercontent.com/15416633/69411618-471b4f80-0d48-11ea-81ca-52af77e1ee91.png

Expected results:
Upgrade to 4.2.8 successfully.

Additional info:

Comment 1 Joep van Delft 2019-11-25 15:31:01 UTC
I believe this has been resolved.

Comment 2 Jian Zhang 2019-11-26 05:37:22 UTC
Yes, it has been signed. Verify it.

mac:~ jianzhang$ oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.7     True        False         106m    Cluster version is 4.2.7
mac:~ jianzhang$ oc patch clusterversion/version --patch '{"spec":{"upstream":"https://openshift-release.svc.ci.openshift.org/graph"}}' --type=merge
clusterversion.config.openshift.io/version patched
mac:~ jianzhang$ oc adm upgrade
Cluster version is 4.2.7

Updates:

VERSION                           IMAGE
4.2.0-0.nightly-2019-11-19-194213 registry.svc.ci.openshift.org/ocp/release@sha256:c7f7edcb19bf05460e68a58e12cdb564c5c161e6a0204ae3ab4d79888663f6a6
4.2.8                             registry.svc.ci.openshift.org/ocp/release@sha256:4bf307b98beba4d42da3316464013eac120c6e5a398646863ef92b0e2c621230
mac:~ jianzhang$ oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.7     True        True          19s     Working towards 4.2.8: 17% complete

Comment 3 Jeff Li 2019-12-02 20:36:40 UTC
Can I ask how you resolved this error?

Comment 5 errata-xmlrpc 2019-12-03 22:43:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3953


Note You need to log in before you can comment on or make changes to this bug.