Bug 1775630 - There is no "olm.skipRange" in ptp-operator csv
Summary: There is no "olm.skipRange" in ptp-operator csv
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: zenghui.shi
QA Contact: huirwang
URL:
Whiteboard:
Depends On:
Blocks: 1776082
TreeView+ depends on / blocked
 
Reported: 2019-11-22 12:56 UTC by huirwang
Modified: 2020-05-04 11:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1776082 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ptp-operator pull 22 0 'None' closed BUG 1775630: allow updating operator to latest entry in channel 2021-01-19 01:18:46 UTC
Github openshift ptp-operator pull 26 0 'None' closed BUG 1775630: fix olm.skipRange version 2021-01-19 01:19:26 UTC
Github openshift ptp-operator pull 28 0 None closed Bug 1775630: support pre-release version upgrade in olm.skipRange 2021-01-19 01:18:46 UTC
Github openshift ptp-operator pull 36 0 None closed update channel to latest 4.4 2021-01-19 01:18:46 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:16:54 UTC

Description huirwang 2019-11-22 12:56:23 UTC
Description of problem:
There is no "olm.skipRange" in ptp-operator csv



Version-Release number of selected component (if applicable):
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.3.0-201911212330-ose-ptp-operator

How reproducible:
always

Steps to Reproduce:
1.Install ptp-operator from web consoel
2.Check ptp-operator csv
3.
huiran-mac:script hrwang$ oc get csv -o yaml -n openshift-ptp | grep "olm.skipRange"
huiran-mac:script hrwang$ 

Actual results:
Due to there is no "olm.skipRange" in ptp-operator csv, will cause ptp-operator cannot upgrade.

Expected results:
There should have "olm.skipRange" in ptp-operator csv

Additional info:

Comment 3 zenghui.shi 2019-12-06 03:51:13 UTC
move to modified as the PR fixing this issue is merged: https://github.com/openshift/ptp-operator/pull/26

Comment 12 errata-xmlrpc 2020-05-04 11:16:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.