Bug 17757 - Conflicting `fonts.alias' file
Conflicting `fonts.alias' file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86-ISO8859-9 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-20 19:06 EDT by Enrico Scholz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 09:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2000-09-20 19:06:09 EDT
When installing XFree86-ISO8859-9-2.1.2-13 a file
/usr/share/fonts/ISO8859-1/misc/fonts.alias will be created.  In this file
there are entries like

| fixed       
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-9

conflicting with the original XFree86 fonts (in
/usr/X11R6/lib/X11/fonts/misc).

So you will get multiple entries for font `fixed'. When using `xterm' this
identifier will be used to determine various fonts and you will get
probably the wrong one (I have seen it at umlauts).


I suggest to remove such duplicate aliases or to comment them out in the
*ISO* packages. ISO8859-2 and ISO8859-7 seems to be ok; but KOI8-R has the
problem too.

Note You need to log in before you can comment on or make changes to this bug.