Bug 1775704 - Pipeline ClusterTasks need to be rendered in Pipeline Overview
Summary: Pipeline ClusterTasks need to be rendered in Pipeline Overview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1778213
TreeView+ depends on / blocked
 
Reported: 2019-11-22 15:58 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Explicit rendering of Tasks on the Pipeline details Consequence: Would create links to non-existent Tasks if the Tasks were actually ClusterTasks Fix: Check the type and render the proper link / visual representation. Result: Able to see both ClusterTasks as well as Tasks appropriately.
Clone Of:
: 1778213 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Seeing Tasks (Not ClusterTasks) (22.35 KB, image/png)
2019-11-22 15:58 UTC, Andrew Ballantyne
no flags Details
YAML showing ClusterTasks (42.20 KB, image/png)
2019-11-22 15:58 UTC, Andrew Ballantyne
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3543 0 'None' closed Bug 1775704: Allow ClusterTasks to be visible on the Pipeline Details page 2020-04-24 18:03:24 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:16:54 UTC

Description Andrew Ballantyne 2019-11-22 15:58:27 UTC
Created attachment 1638774 [details]
Seeing Tasks (Not ClusterTasks)

Description of problem:
ClusterTasks are not shown when viewing a Pipeline that uses ClusterTasks instead of the regular tasks.


Version-Release number of selected component (if applicable): 4.3


How reproducible: 100%


Steps to Reproduce:
1. Load up a Pipeline that uses ClusterTasks
2. Be on the Overview tab

Actual results:
See that they are showing as Tasks and not ClusterTasks (the link will 404 if used)

Expected results:
To see ClusterTask (CT) references instead

Additional info:

Comment 1 Andrew Ballantyne 2019-11-22 15:58:51 UTC
Created attachment 1638775 [details]
YAML showing ClusterTasks

Comment 3 Ruchir Garg 2020-03-02 06:38:44 UTC
Bulk assigning all to Gajanan for verification.

Comment 4 Gajanan More 2020-03-02 11:05:29 UTC
https://issues.redhat.com/browse/ODC-2385 verified by Sanket Pathak

Comment 6 errata-xmlrpc 2020-05-04 11:16:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.