Bug 1775720 - default template for metering report for editor should use v1 instead of v1apha1
Summary: default template for metering report for editor should use v1 instead of v1apha1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.2.z
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1772694 1776339
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-22 16:22 UTC by David Taylor
Modified: 2019-12-11 22:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1775719
Environment:
Last Closed: 2019-12-11 22:36:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3523 'None' 'open' 'Bug 1775720: Backport to 4.2 - Chargeback Reports and ReportQueries change to v1 apiVersion' 2019-12-02 15:18:02 UTC
Red Hat Product Errata RHBA-2019:4093 None None None 2019-12-11 22:36:16 UTC

Description David Taylor 2019-11-22 16:22:03 UTC
+++ This bug was initially created as a clone of Bug #1775719 +++

+++ This bug was initially created as a clone of Bug #1772694 +++

Description of problem:
The default report and ReportQuries generated by the UI that populated the UI editor should ue `v1` instead of `v1alpha``.  The resulting report can still be generated but we should use the proper versioning going forward in case support for `v1apha1` is dropped.

Version-Release number of selected component (if applicable):
OCP >= 4.2

How reproducible:
always

Steps to Reproduce:
1.  Have metering installed.
2.  Administration->Chargeback
3.  Click on Create / CreateReportQuery
4.  The default template will show that it's using `v1alpha1`

This applies to creating a Report as well as ReportQuery
https://github.com/openshift/console/blob/41940c686cf55c8ed6331b539c9f78b8f49d174b/frontend/public/models/yaml-templates.ts#L200

https://github.com/openshift/console/blob/41940c686cf55c8ed6331b539c9f78b8f49d174b/frontend/public/models/yaml-templates.ts#L212

Actual results:
apiVersion: metering.openshift.io/v1alpha1

Expected results:
apiVersion: metering.openshift.io/v1


Additional info:

Comment 2 shahan 2019-12-03 06:37:18 UTC
Now The api is using metering.openshift.io/v1
4.2.0-0.nightly-2019-12-03-015548

Comment 4 errata-xmlrpc 2019-12-11 22:36:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4093


Note You need to log in before you can comment on or make changes to this bug.