Bug 1775767 - [abrt] libreoffice-core: (anonymous namespace)::signalHandlerFunction(int, siginfo_t*, void*)(): soffice.bin killed by SIGABRT
Summary: [abrt] libreoffice-core: (anonymous namespace)::signalHandlerFunction(int, si...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:7b4c4cee2cb565bf4e7d8c1fe52...
: 1794002 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-22 18:31 UTC by Andrew
Modified: 2020-02-19 12:47 UTC (History)
6 users (show)

Fixed In Version: libreoffice-6.3.3.2-7.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-01 00:46:29 UTC


Attachments (Terms of Use)
File: backtrace (220.81 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: cgroup (227 bytes, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: core_backtrace (136.57 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: cpuinfo (2.53 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: dso_list (22.50 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: environ (6.48 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: limits (1.29 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: maps (145.53 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: mountinfo (5.68 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: open_fds (2.46 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details
File: proc_pid_status (1.33 KB, text/plain)
2019-11-22 18:32 UTC, Andrew
no flags Details

Description Andrew 2019-11-22 18:31:59 UTC
Description of problem:
convert many docx to pdf through unoconv 0.6, some of docx is big(about 300 sheets

Version-Release number of selected component:
1:libreoffice-core-6.3.3.2-2.fc31

Additional info:
reporter:       libreport-2.11.3
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --headless --invisible --nocrashreport --nodefault --nofirststartwizard --nologo --norestore --accept=socket,host=127.0.0.1,port=2002,tcpNoDelay=1;urp;StarOffice.ComponentContext
crash_function: (anonymous namespace)::signalHandlerFunction(int, siginfo_t*, void*)
executable:     /usr/lib64/libreoffice/program/soffice.bin
journald_cursor: s=fdd3a9b3d71a4165b14befb910bb9dcc;i=71138;b=412eb4896ac8414182320a9c8d10cec5;m=a68533392;t=597f24a088857;x=8cb1674438f3b8d1
kernel:         5.3.11-300.fc31.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (1 frames)
 #2 (anonymous namespace)::signalHandlerFunction(int, siginfo_t*, void*) at /usr/src/debug/libreoffice-6.3.3.2-2.fc31.x86_64/sal/osl/unx/signal.cxx:500

Potential duplicate: bug 1690645

Comment 1 Andrew 2019-11-22 18:32:04 UTC
Created attachment 1638850 [details]
File: backtrace

Comment 2 Andrew 2019-11-22 18:32:06 UTC
Created attachment 1638851 [details]
File: cgroup

Comment 3 Andrew 2019-11-22 18:32:09 UTC
Created attachment 1638852 [details]
File: core_backtrace

Comment 4 Andrew 2019-11-22 18:32:10 UTC
Created attachment 1638853 [details]
File: cpuinfo

Comment 5 Andrew 2019-11-22 18:32:12 UTC
Created attachment 1638854 [details]
File: dso_list

Comment 6 Andrew 2019-11-22 18:32:14 UTC
Created attachment 1638855 [details]
File: environ

Comment 7 Andrew 2019-11-22 18:32:15 UTC
Created attachment 1638856 [details]
File: limits

Comment 8 Andrew 2019-11-22 18:32:18 UTC
Created attachment 1638857 [details]
File: maps

Comment 9 Andrew 2019-11-22 18:32:20 UTC
Created attachment 1638858 [details]
File: mountinfo

Comment 10 Andrew 2019-11-22 18:32:21 UTC
Created attachment 1638859 [details]
File: open_fds

Comment 11 Andrew 2019-11-22 18:32:23 UTC
Created attachment 1638860 [details]
File: proc_pid_status

Comment 12 Andrew 2019-11-22 19:51:12 UTC
Similar problem has been detected:


reporter:       libreport-2.11.3
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --headless --invisible --nocrashreport --nodefault --nofirststartwizard --nologo --norestore --accept=socket,host=127.0.0.1,port=2002,tcpNoDelay=1;urp;StarOffice.ComponentContext
crash_function: (anonymous namespace)::signalHandlerFunction(int, siginfo_t*, void*)
executable:     /usr/lib64/libreoffice/program/soffice.bin
journald_cursor: s=fdd3a9b3d71a4165b14befb910bb9dcc;i=72535;b=412eb4896ac8414182320a9c8d10cec5;m=c9aad8839;t=597f47c62dcfd;x=3b73bf4d43fb60be
kernel:         5.3.11-300.fc31.x86_64
package:        1:libreoffice-core-6.3.3.2-2.fc31
reason:         soffice.bin killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
xsession_errors:

Comment 13 Caolan McNamara 2019-11-22 20:43:37 UTC
looks like the sidebar is torn down after the thing it relies on has been deleted and set to null, though locally with "normal" case I get things in the expected order

Comment 14 Caolan McNamara 2019-11-23 20:05:22 UTC
can you share how you invoke unoconv to do your conversion ?

Comment 15 Andrew 2019-11-23 20:20:29 UTC
in python torando app we use libreoffice to convert docx, xls, odt to pdf
unoconv version is 0.6, in script we runs it throught subprocess(tornado.process.Subprocess) with this args 
path_to_unoconve, "-f", "pdf", "-T", "10", file_path

unoconv starts many times in parallel

Comment 16 Caolan McNamara 2019-11-28 10:05:25 UTC
I can't reproduce it, but I can try a speculative fix based on the bt and include it in the next build to see if it makes a difference

Comment 17 Fedora Update System 2019-11-29 09:02:57 UTC
FEDORA-2019-0902559a0b has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0902559a0b

Comment 18 Caolan McNamara 2019-11-29 09:25:29 UTC
does that make a blind bit of difference, or does the crash just move to another place ?

Comment 19 Fedora Update System 2019-11-30 01:19:47 UTC
libreoffice-6.3.3.2-7.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0902559a0b

Comment 20 Fedora Update System 2019-12-01 00:46:29 UTC
libreoffice-6.3.3.2-7.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 lzavacky 2020-01-22 13:30:28 UTC
*** Bug 1794002 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.