Bug 1775851 - Gitlab Git Detection Appears to Run Forever
Summary: Gitlab Git Detection Appears to Run Forever
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1778205
TreeView+ depends on / blocked
 
Reported: 2019-11-22 23:48 UTC by Andrew Ballantyne
Modified: 2020-05-04 11:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Wrong access point to gitlab API. Fetched fuzzy in repo names as well as repo summaries. Consequence: We would fetch a near infinite amount of items for common words due to heavy reuse of generic words. "url" and "gitlab" are commonly used in gitlab being used in either their repo name or the summary that can accompany it. Fix: Focus more specifically on the one we want and singularly get back the one that the user provided us. Result: Fast response as it only fetched for one - the one the user asked us to fetch.
Clone Of:
: 1778205 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:28 UTC
Target Upstream Version:
gamore: needinfo-
gamore: needinfo-
gamore: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3550 0 'None' closed Bug 1775851: Gitlab Properly Detects Repos 2020-02-06 16:55:44 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:17:26 UTC

Description Andrew Ballantyne 2019-11-22 23:48:09 UTC
Description of problem:
Gitlab detection would fetch "forever" in some cases. 

Version-Release number of selected component (if applicable): 4.3


How reproducible: 100%


Steps to Reproduce:
1. Navigate to the import git form
2. Using one of the following URLs paste it into the git url and click away from the field
  - https://gitlab.com/wrong/url
  - https://gitlab.com/gitlab-org/gitlab

Actual results:
It would validate forever and the network would just keep fetching over and over. Persists if you leave the page.

Expected results:
Match the repo in a timely manner.

Additional info:

Comment 2 Gajanan More 2019-12-04 11:13:27 UTC
I have validated the bug and it is not reproducible. @Andrew You can close this bug.

Comment 3 Andrew Ballantyne 2019-12-04 13:41:04 UTC
Please post the ci/nightly version you verified it on and you should be able to resolve it(?) Sanket has closed Bugzillas before, perhaps reach out to him for assistance if you have issues.

Comment 4 Gajanan More 2019-12-05 06:24:23 UTC
To validate this bug, I used '4.3.0-0.nightly-2019-12-04-054458' build and it has validated on Chrome 78.0.3904.108. @Andrew I need to be a QE Contact to update this issue. I have asked Ruchir to make me as a QE Contact and will update the bug afterward.

Comment 5 errata-xmlrpc 2020-05-04 11:16:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.