Bug 1775889 - Unable to enable 'Compute Resources-Azure' plugin , ERROR: Unrecognised option '--enable-foreman-plugin-azure'
Summary: Unable to enable 'Compute Resources-Azure' plugin , ERROR: Unrecognised optio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - Azure
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: 6.7.0
Assignee: Evgeni Golov
QA Contact: vijsingh
URL:
Whiteboard:
Depends On:
Blocks: 1775890
TreeView+ depends on / blocked
 
Reported: 2019-11-23 09:20 UTC by vijsingh
Modified: 2020-04-14 13:27 UTC (History)
3 users (show)

Fixed In Version: foreman-installer-1.24.0-0.7.RC3,satellite-installer-6.7.0.5-1.beta,tfm-rubygem-foreman_azure_rm-2.0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-14 13:27:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:1454 None None None 2020-04-14 13:27:37 UTC

Description vijsingh 2019-11-23 09:20:21 UTC
Description of problem:

Unable to enable 'Compute Resources-Azure' plugin , ERROR: Unrecognised option '--enable-foreman-plugin-azure'


Version-Release number of selected component (if applicable):

@Satellite 6.7.0 snap 3.0

How reproducible:

Always

Steps to Reproduce:
1.

[root@qe-sat6-feature-rhel7 ~]# satellite-installer --enable-foreman-plugin-azure
ERROR: Unrecognised option '--enable-foreman-plugin-azure'

See: 'satellite-installer --help'


[root@qe-sat6-feature-rhel7 ~]# satellite-installer -S satellite --full-help|grep -i azure
[root@qe-sat6-feature-rhel7 ~]# 


Actual results:

ERROR: Unrecognised option '--enable-foreman-plugin-azure'

Expected results:

Should be able to enable/disable 'Compute Resources-Azure' plugin

Additional info:

Comment 4 vijsingh 2019-12-02 07:46:27 UTC
ON_QA Failed

@Satellite 6.7.0 snap 4.0

___________________________
[root@qe-sat6-bm1 ~]satellite-installer --enable-foreman-plugin-azure
ERROR: Unrecognised option '--enable-foreman-plugin-azure'
See: 'satellite-installer --help'
[root@qe-sat6-bm1 ~]# 
__________________________

Comment 10 vijsingh 2019-12-17 06:37:19 UTC
ON_QA Verified

@Satellite 6.7.0 snap 6.0

Steps/Observations:

____________________________________________________________________
[root@dhcp-2-24 ~]# satellite-installer --enable-foreman-plugin-azure --enable-foreman-cli-azure
Package versions are locked. Continuing with unlock.
Installing             Done                                               [100%] [..........................................................................................]
  Success!
  * Satellite is running at https://dhcp-2-24.vms.sat.rdu2.redhat.com

  * To install an additional Capsule on separate machine continue by running:

      capsule-certs-generate --foreman-proxy-fqdn "$CAPSULE" --certs-tar "/root/$CAPSULE-certs.tar"

  * To upgrade an existing 6.6 Capsule to 6.7:
      Please see official documentation for steps and parameters to use when upgrading a 6.6 Capsule to 6.7.

  The full log is at /var/log/foreman-installer/satellite.log


[root@dhcp-2-24 ~]# hammer compute-resource create --help|grep -i azure
 --app-ident APP_IDENT                       Client ID for AzureRm
 --provider PROVIDER                         Providers include Libvirt, Ovirt, EC2, Vmware, Openstack, GCE, AzureRm
 --secret-key SECRET_KEY                     Client Secret for AzureRm
 --sub-id SUB_ID                             Subscription ID for AzureRm
 --tenant TENANT  
____________________________________________________________________

1. Able to enable plugin.
2. hammer commands shows after enable.
3. APIdoc is showing the related APIs details .

Comment 13 errata-xmlrpc 2020-04-14 13:27:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:1454


Note You need to log in before you can comment on or make changes to this bug.