Bug 177589 - gnome-mount does not seem to be working at all
gnome-mount does not seem to be working at all
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-11 18:27 EST by Michal Jaegermann
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 09:39:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-01-11 18:27:23 EST
Description of problem:

gnome-mount is supposed to be a "replacement for the mount, umount and eject
commands that uses HAL to do all the heavy lifting".  It looks that lifting
is so far way too heavy for it.  Not sure if fault are really those of dbus,
hal, nautilus or gnome-mount.  None of hotplug devices mounts (or show up
other than in log files), floppy is missing but at least I have
/media/cdrecorder entry in /etc/fstab and a corresponding icon in "Computer"
window.

Picking up "Mount Volume" on that icon, with a data CD in a drive, has no
effect at all.  I can do 'mount -r /media/cdrecorder' which works and
causes a corresponding icon to show up on a desktop and in a "Computer" window.
If now I will try "Eject" on those icons menus this does not eject anything
although 'eject' from a command line is fine.

'gnome-mount --device /dev/hdc' returns silently and immediately.  OTOH
'gnome-eject --device /dev/hdc' does not eject anything too but at least
prints the following:


** Message: Ejecting UDI '/org/freedesktop/Hal/devices/volume_part_1_size_561516544'

** (gnome-mount:2998): WARNING **: Eject failed for
/org/freedesktop/Hal/devices/volume_part_1_size_561516544
org.freedesktop.DBus.Error.AccessDenied : A security policy in place prevents
this sender from sending this message to this recipient, see message bus
configuration file (rejected message had interface
"org.freedesktop.Hal.Device.Volume" member "Eject" error name "(unset)"
destination "org.freedesktop.Hal")

For a device with this particular udi above lshal reports this:

udi = '/org/freedesktop/Hal/devices/volume_part_1_size_561516544'
  info.udi = '/org/freedesktop/Hal/devices/volume_part_1_size_561516544'  (string)
  info.product = 'Volume'  (string)
  volume.disc.is_svcd = false  (bool)
  volume.disc.is_vcd = false  (bool)
  volume.disc.is_videodvd = false  (bool)
  volume.disc.is_rewritable = false  (bool)
  volume.disc.is_appendable = false  (bool)
  volume.disc.is_blank = false  (bool)
  volume.disc.has_data = true  (bool)
  volume.disc.has_audio = false  (bool)
  volume.disc.type = 'cd_r'  (string)
  volume.size = 561516544  (0x21781000)  (uint64)
  volume.num_blocks = 1096712  (0x10bc08)  (int)
  volume.block_size = 2048  (0x800)  (int)
  info.capabilities = {'volume', 'block'} (string list)
  info.category = 'volume'  (string)
  volume.is_partition = true  (bool)
  volume.is_disc = true  (bool)
  volume.is_mounted = true  (bool)
  volume.mount_point = '/media/cdrecorder'  (string)
  volume.label = ''  (string)
  volume.uuid = ''  (string)
  volume.fsversion = ''  (string)
  volume.fsusage = ''  (string)
  volume.fstype = ''  (string)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_model_LITE_ON_LTR_52327S'  (string)
  block.is_volume = true  (bool)
  block.minor = 0  (0x0)  (int)
  block.major = 22  (0x16)  (int)
  block.device = '/dev/hdc'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  info.parent = '/org/freedesktop/Hal/devices/storage_model_LITE_ON_LTR_52327S'
 (string)
  linux.sysfs_path_device = '/sys/block/hdc/fakevolume'  (string)
  linux.sysfs_path = '/sys/block/hdc/fakevolume'  (string)

and everywhere where "org.freedesktop.Hal.Device.Volume.method_names"
show up this list looks the same, ie. "{ 'Mount', 'Unmount', 'Eject'}".

Version-Release number of selected component (if applicable):
gnome-mount-0.2-1

How reproducible:
always
Comment 1 John (J5) Palmieri 2006-01-11 18:39:06 EST
Did you reboot your machine after upgrading?
Comment 2 Michal Jaegermann 2006-01-11 19:09:29 EST
> Did you reboot ...

Yes. Updates included, among other things, kernel and glibc.
Comment 3 John (J5) Palmieri 2006-01-11 19:12:57 EST
what about se-linux?
Comment 4 Michal Jaegermann 2006-01-11 23:40:32 EST
selinux is turned off
Comment 5 John (J5) Palmieri 2006-01-17 09:49:36 EST
This all works for me.  Please update your complete system to the latest rawhide
and tell me if it still is not working.
Comment 6 John (J5) Palmieri 2006-01-17 11:20:02 EST
Actually wait a couple of days.  Right as of yesterday it got completely borked
in Rawhide.
Comment 7 Michal Jaegermann 2006-01-21 21:45:54 EST
I tried what will happen with gnome-mount-0.4-0.cvs20060117 and other current
updates.  Results are at least strange.

First nothing is mounted by whatever mechanisms are supposed to do that on
a desktop.  While trying

   gnome-mount -d /dev/fd0

I am getting invariably an alert "Unable to mount media. There is probably no
media in the drive".  There is no difference if the here are media in a drive 
or not. The same alert shows up when I try to use "Mount" menu entry on a floppy
icon after I will open "Computer" browse window.

As root I can do 'mount /dev/fd0 /media/floppy'.  No problems here and this
causes a floppy icon to show up on a desktop and also an icon in a "Computer"
window changes shape.  Then I can unmount this floppy with a mouse on
an "Unmount Volume" menu entry on that icon.

In that "Computer" window there is a CD-ROM icon as long as I will not put
a CD into a drive.  After some access, with a disk spinning and ligths showing
up a on drive, that icon disappears from that window and gnome-mount silently
ignores /dev/hdc - which happens to be a correct device.  I do not see anything
weird in an output of lshal but maybe I am missing something.  That icon
returns when I will take out my CD.

I can do as well 'mount -r /dev/hdc /media/cdrecorder' but this time this
does not make a corresponding icon to show up.  Attempts to umount or eject
that CD using 'gnome-(u)mount' are ignored too although 'eject' does not
have any problems.

Media connected via USB are also silently ignored by 'gnome-mount' although
in logs I see that they are correctly detected and recognized.

Adding '-v' flag to 'gnome-mount' invocations does not produce any extra output.

Is that detail that this is on x86_64 somehow relevant?
Comment 8 Michal Jaegermann 2006-02-05 11:56:09 EST
I tested on another machine, i386 this time, with the current rawhide on it.
USB cannot be done as it is broken hardware-wise on that particular box.
Floppy behaves exactly the same way as described in comment #7.

There is a difference with CDs though.  They are still not mounted on an insert
even if all required boxes are marked in preferences.  I checked.  OTOH a drive
icon does not vanish from "Computer" browse window and "Mount volume" on an icon
menu has a desired effect - i.e. media are mounted and a corresponding icon
shows up on a desktop and it can be used to eject.

Auto-mounting on insert used to work on this machine in the past and floppies
were mountable too.  They stil are, with a help of 'mount', so there is nothing
wrong hardwarewise.
Comment 9 David Bentley 2006-02-05 16:10:16 EST
I have a Pioneer DVD-303 scsi dvd drive which exhibits the following problem.

On inserting media CD or DVD (audio or data CD and data DVD) the drive appears
to see the media (spins up etc...) but on trying to use the mount menu
option I get a small box with a white cross on an icon and a button with OK
on it and another box titled error with a message saying Unable to mount media 
and suggesting that there is probably no media in the drive.
Comment 10 David Bentley 2006-02-05 16:10:55 EST
Adding myself to the Cc list
Comment 11 John (J5) Palmieri 2006-02-06 10:47:57 EST
A new version of HAL should be released upstream shortly.  It should fix the
floppy problem.  I'm not sure about teh CD-ROM problems.  When it is released I
will update this bug.
Comment 12 Matthias Clasen 2006-02-15 16:16:41 EST
Is anybody still seeing these issues with current rawhide / test3 ?
Comment 13 Michal Jaegermann 2006-02-23 00:11:19 EST
> Is anybody still seeing these issues with current rawhide / test3 ?

There are changes but things are far from sane and/or consistent.
My setup is current now with all available updates applied.

I see different behaviour on non-root and root accounts.

First non-root. CDs and a USB storage which I can try indeed are now
mounted automatically.  Beyond a totally broken tendency to mount at
a mount point derived from some random string this more or less behaves.
Who invented this particular extra heavy brain-damage and where is documented
how to get around that?  I know for the fact that this will be a serious
obstacle for people with a bad eyesight and surely will have many other nasty
side effects.

Floppies have to be mounted by clicking on a floppy icon in a "Computer"
window.  So far so good but they cannot be unmounted by picking up
"Unmount volume" from a corresponding floppy menu.  That action is silently
ignored.  Typing in a terminal window

    gnome-mount -e -v -d /dev/fd0

does unmount that floppy, silently despite of -v, but it leaves behind
/media/floppy directory owned by root.  The next attempt to mount floppy
mounts it on /media/floppy-1, which is left behind, and repeating that
operation quickly fills /media directory with a garbage which only root
can remove.

BTW 'gnome-umount -e -v -d /dev/fd0' silently returns doing nothing
despite that '-e' option is listed by '--help'.  Dropping '-e' makes this work.

For root the situation is somewhat different.  Anything mountable behaves
like a floppy.  That means that it does not automount but it has to be
explicitely coached with a mouse.  It does not matter which combinations
of boxes are checked in "Preferences" for "Removable Drives ...".

Unmounting from an icon menu works for all kinds of media, including floppy,
but it still leaves behind /media/floppy, /media/floppy-1, and ad nauseam.

Anything of the above should be split into a separate bug reports?
Comment 14 John (J5) Palmieri 2006-02-23 09:39:14 EST
Michal,

Thanks for the detailed bug reports but can I ask you not to be abusive in them.
 It's not fun reading lines like "extra heavy brain-damage" before my morning
coffee.

As for the naming we take the volume label of the device.  I would mark that as
not a bug.  If you disagree that is something to descuss upstream.

Gnome-mount being broken and not removing directories should be opened up as a
new bug however.

The root issue should also be opened up as a new bug but I suspect it is a
security measure and perhaps we should note it on the preference capplet but
that is low priority and another thing upstream should handle.  Thanks.

Closing this bug.
Comment 15 Michal Jaegermann 2006-02-23 19:41:06 EST
> As for the naming we take the volume label of the device.  I would mark that as
> not a bug.

That what I was afraid of.  Otherwise I would file that as an evident
bug.  No, you do not take the volume label of the device. You try to 
and this sometimes works and sometimes it does not.  Even when this happens
to work, for what gains it is beyond comprehension as at least a CD volume
label shows up on a desktop even if a mountpoint has not label-derived, it is
still a random, not very well defined string and results are not pretty.

>  If you disagree that is something to descuss upstream.

Past experience shows that this is a total waste of time.  I would settle
for a well defined and documented way to work around that damage.

Note You need to log in before you can comment on or make changes to this bug.