Bug 177627 - Anaconda FTP & HTTP installs fail
Summary: Anaconda FTP & HTTP installs fail
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-12 14:45 UTC by Jasper O. Hartline
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 14:51:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jasper O. Hartline 2006-01-12 14:45:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
Anaconda on FC5t1-i386-boot.iso fails trying any type of network install.
The release notes say FTP and HTTP are supported, they don't work however.
/
They will both fail missing email.Utils from something in pyurlgrabber.lib or something. Obviously a missing Python module that tries to get imported.

I would also like to state something about NFS, it also fails, however that isn't relevant, what is relevant is NFS could use an option to use .ISO files as install media or the os/Fedora/{base,RPMS} type layout.

I'm sure there is a way to mount CD#1 in loopback over NFS and retrieve the stage files. Thanks for your time guys.

Version-Release number of selected component (if applicable):
anaconda-10.90.2 Fedora Core 5 Test 1

How reproducible:
Always

Steps to Reproduce:
1. Run: linux text
2. Choose FTP, HTTP, or NFS service installation
3. Watch it fail, FTP and HTTP.
  

Actual Results:  Anaconda raises exceptions due to missing email.Utils module.
Anaconda NFS likewise fails raising an exception.

Expected Results:  One of the methods should have worked.

Additional info:

No additional info at this time.

Comment 1 Chris Lumens 2006-01-12 14:51:28 UTC
This should be fixed for test2.


Note You need to log in before you can comment on or make changes to this bug.