Bug 1776272 - [OSP] Installer fails without project_name
Summary: [OSP] Installer fails without project_name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Mike Fedosin
QA Contact: David Sanz
URL:
Whiteboard:
: 1785705 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-25 12:00 UTC by Pierre Prinetti
Modified: 2020-05-04 11:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2726 'None' closed Bug 1776272: OpenStack: fix getting service catalog 2020-09-09 01:46:56 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:17:24 UTC

Description Pierre Prinetti 2019-11-25 12:00:13 UTC
Description of problem:

The creation of the `install-config` fails if the `clouds.yaml` lacks the property `project_name`.

Version-Release number of the following components:

```
unreleased-master-2182-g8e75675f373d7ca46ec7fa4b4156ce75287735d1
built from commit 8e75675f373d7ca46ec7fa4b4156ce75287735d1
release image registry.svc.ci.openshift.org/origin/release:4.3
```

How reproducible:
reliably

Steps to Reproduce:
1. Have a clouds.yaml with project_id
2. Remove project_name from clouds.yaml if any
3. Run `openshift-install create install-config`
4. Follow the instructions
5. After "FlavourName", the wizard crashes while collection information prior to asking for the base domain.

Actual results:

```
> ./openshift-install --dir=foo create install-config
? SSH Public Key /Users/chris/.ssh/id_rsa.pub
? Platform openstack
? Cloud imke-test
? ExternalNetwork provider
? APIFloatingIPAddress 185.116.247.101
? FlavorName m1.medium
FATAL failed to fetch Install Config: failed to fetch dependency of "Install Config": failed to fetch dependency of "Base Domain": failed to generate asset "Platform": Authentication failed
```

Expected results:

* Wizard asking for BaseDomain
* Creation of install-config.yaml 

Additional info:
* Originally reported on Github by Christoph Glaubitz https://github.com/openshift/installer/issues/2710

Comment 1 David Sanz 2019-12-17 10:52:05 UTC
Verified on 4.4.0-0.nightly-2019-12-16-171529


[morenod@morenod-laptop tmp]$ tar xzvf openshift-install-linux-4.4.0-0.nightly-2019-12-16-171529.tar.gz 
README.md
openshift-install

$ ./openshift-install create cluster
? SSH Public Key /home/xx/.ssh/openshift-qe.pub
? Platform openstack
INFO Credentials loaded from file "/tmp/clouds.yaml" 
? Cloud openstack
? ExternalNetwork xxxx
? APIFloatingIPAddress xxxx
? FlavorName xxxx
? Base Domain xxxxx
? Cluster Name morenod
? Pull Secret [? for help]

Comment 2 Martin André 2020-01-09 15:33:17 UTC
*** Bug 1785705 has been marked as a duplicate of this bug. ***

Comment 4 errata-xmlrpc 2020-05-04 11:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.