Bug 177632 - problems with StarDesktop.loadComponentFromURL
problems with StarDesktop.loadComponentFromURL
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-12 10:58 EST by zingale
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-12 11:23:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
header file for sample macro (348 bytes, application/octet-stream)
2006-01-12 10:59 EST, zingale
no flags Details
macro that crashes (493 bytes, application/octet-stream)
2006-01-12 11:00 EST, zingale
no flags Details
sample file for macro (9.72 KB, image/png)
2006-01-12 11:01 EST, zingale
no flags Details

  None (edit)
Description zingale 2006-01-12 10:58:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I am trying to use the OOoLatexMacro package with Openoffice Impress (see http://ooolatex.sourceforge.net/)

When you run this, an error is generated, and the debugger window pops up.  After a few exchanged with the developer, it seems that the problem is confined to the Linux version of Openoffice (and perhaps even just Fedora).  The developer posted some comments on the oooforum:

http://www.oooforum.org/forum/viewtopic.phtml?t=29778

A simple test case is to try running the macro:

Sub Main
Dim NoArg()
cURL = "file:///home/<login>/tmpfile.png"
oDrawDoc = StarDesktop.loadComponentFromURL( cURL, "_blank", 0, NoArg() )
MsgBox oDrawDoc.DBG_properties
End sub 

under Fedora, this crashes, with the error "BASIC runtime error. Object variable not set", and the debugger pops up with the "MsgBox..." line highlighted.

There is some evidence in the oooforum thread that this works fine in Mandriva.

I am attaching the macro and script to reproduce this problem.



Version-Release number of selected component (if applicable):
2.0.1-143.2.1

How reproducible:
Always

Steps to Reproduce:
1. run the macro
2.
3.
  

Actual Results:  debugger pops up.

Expected Results:  image should appear

Additional info:
Comment 1 zingale 2006-01-12 10:59:55 EST
Created attachment 123121 [details]
header file for sample macro
Comment 2 zingale 2006-01-12 11:00:36 EST
Created attachment 123122 [details]
macro that crashes
Comment 3 zingale 2006-01-12 11:01:16 EST
Created attachment 123123 [details]
sample file for macro
Comment 4 Caolan McNamara 2006-01-12 11:23:20 EST
Install openoffice.org-graphicfilter to get the .png and other bitmap and vector
import filters

Note You need to log in before you can comment on or make changes to this bug.