Bug 1776361 - It's impossible to identify which object the context menu is associated in the topology view
Summary: It's impossible to identify which object the context menu is associated in th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
: 1776463 (view as bug list)
Depends On:
Blocks: 1776401
TreeView+ depends on / blocked
 
Reported: 2019-11-25 14:27 UTC by Serena
Modified: 2020-05-04 11:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1776401 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3566 0 'None' closed Bug 1776361: Show hover treatment for context menu's reference item 2020-04-28 20:20:41 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:17:24 UTC

Description Serena 2019-11-25 14:27:42 UTC
Description of problem:

It's impossible to identify which object the context menu is associated in the topology view.  This could cause major usability issues.

Is it possible to keep the hover state of the node when it's context menu is displayed?  

Version-Release number of selected component (if applicable):


How reproducible:

Consistently reproducible

Steps to Reproduce:
Right click on a component in topology, you will see the context menu issued, but there is no visual connection with anything in the view.

Actual results:


Expected results:


Additional info:

Comment 1 Jeff Phillips 2019-11-25 17:38:07 UTC
*** Bug 1776463 has been marked as a duplicate of this bug. ***

Comment 3 Gajanan More 2020-03-03 12:53:34 UTC
I have validated this bug on 
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108
Marking this as done.

Comment 5 errata-xmlrpc 2020-05-04 11:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.