Bug 1776704 - [RFE] It's better to change annotations.summary to annotations.message for alerting rules under CloudCredentialOperator group
Summary: [RFE] It's better to change annotations.summary to annotations.message for a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Joel Diaz
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1777025
TreeView+ depends on / blocked
 
Reported: 2019-11-26 07:59 UTC by Junqi Zhao
Modified: 2020-05-04 11:17 UTC (History)
0 users

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1777025 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:17:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
no message for CCOProvisioningFailed (153.77 KB, image/png)
2019-11-26 07:59 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 140 'None' closed Bug 1776704: change prometheus from summary to message 2020-05-14 19:03:42 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:17:36 UTC

Description Junqi Zhao 2019-11-26 07:59:20 UTC
Created attachment 1639718 [details]
no message for CCOProvisioningFailed

Description of problem:
Alerting rules under CloudCredentialOperator group
CCOTargetNamespaceMissing
CCOProvisioningFailed
CCODeprovisioningFailed
CCOInsufficientCloudCreds
CCOperatorDown

take CCOProvisioningFailed for example, details:
*******************
alert: CCOProvisioningFailed
expr: cco_credentials_requests_conditions{condition="CredentialsProvisionFailure"}
  > 0
for: 5m
labels:
  severity: warning
annotations:
  summary: CredentialsRequest(s) unable to be fulfilled
*******************
should be like
annotations:
  message: CredentialsRequest(s) unable to be fulfilled

otherwise, we can not see the messages from web console, see the attached picture

Version-Release number of selected component (if applicable):


How reproducible:
4.3.0-0.nightly-2019-11-25-153929

Steps to Reproduce:
1. See the description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 errata-xmlrpc 2020-05-04 11:17:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.