Bug 1776897 - Race between pools recovery and previous request_vifs
Summary: Race between pools recovery and previous request_vifs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.0
Assignee: Luis Tomas Bolivar
QA Contact: GenadiC
URL:
Whiteboard:
: 1776896 (view as bug list)
Depends On: 1776894
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-26 14:33 UTC by Luis Tomas Bolivar
Modified: 2020-01-23 11:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1776894
Environment:
Last Closed: 2020-01-23 11:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 100 0 'None' closed [release-4.3] Bug 1776897: Ensure pools population does not happen until pools are recovered 2020-04-16 15:22:47 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:14:48 UTC

Description Luis Tomas Bolivar 2019-11-26 14:33:13 UTC
+++ This bug was initially created as a clone of Bug #1776894 +++

When kuryr-controller gets restarted, and before the pools are recovered, there is some pools repopulation events triggered due to handling events previous to the kuryr-controller restart. This leads to unneeded repopulation actions as well as delayed pools recovery

Comment 1 Luis Tomas Bolivar 2019-11-27 07:42:57 UTC
*** Bug 1776896 has been marked as a duplicate of this bug. ***

Comment 3 Itzik Brown 2019-12-11 15:50:23 UTC
Verified using:
4.3.0-0.nightly-2019-12-11-073659

Ran the conformance test, during the run restarted the controller and saw the following message.
Kuryr-controller not yet ready to populate pools

Comment 5 errata-xmlrpc 2020-01-23 11:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.