Bug 1777144 - operator-lifecycle-manager-packageserver fails to update with OwnerConflict and RequirementsUnknown events
Summary: operator-lifecycle-manager-packageserver fails to update with OwnerConflict a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Daniel Sover
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
Depends On:
Blocks: 1796913
TreeView+ depends on / blocked
 
Reported: 2019-11-27 02:26 UTC by rvanderp
Modified: 2020-05-04 11:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1796913 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:17:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1171 'None' closed Bug 1777144: packageserver update fails to adopt APIService 2020-08-03 12:23:59 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:18:08 UTC

Description rvanderp 2019-11-27 02:26:31 UTC
Description of problem:
When updating from 4.1.24 to 4.2.7, update of the operator-lifecycle-manager-packageserver fails with events `unable to adopt APIService` and `requirements not yet checked`.  

Version-Release number of selected component (if applicable):
4.2.7

How reproducible:
Have only seen on this specific cluster, but the upgrade is blocked

Steps to Reproduce:
1. Update cluster from 4.1.24 to 4.2.7
2. Check the state of the `operator-lifecycle-manager-packageserver`
3.

Actual results:
operator-lifecycle-manager-packageserver is failing to update

Expected results:
operator-lifecycle-manager-packageserver should update

Additional info:
This issue may be related to bug https://bugzilla.redhat.com/show_bug.cgi?id=1723818

Comment 16 errata-xmlrpc 2020-05-04 11:17:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.