Bug 1777204 - [IPI][Baremetal] Many haproxy processes hanging around due to monitor not closing connections.
Summary: [IPI][Baremetal] Many haproxy processes hanging around due to monitor not clo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Yossi Boaron
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-27 07:03 UTC by Yossi Boaron
Modified: 2020-05-04 11:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:17:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1274 None closed Bug 1777204: [Baremetal] verify that 'old' HAProxy processes being deleted after HAProxy reload. 2020-10-21 11:58:01 UTC
Red Hat Bugzilla 1771566 unspecified CLOSED [IPI][OpenStack] Many haproxy processes hanging around due to monitor not closing connections. 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:18:08 UTC

Description Yossi Boaron 2019-11-27 07:03:37 UTC
Description of problem:

Duplication of https://bugzilla.redhat.com/show_bug.cgi?id=1771566 for Baremetal environment

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Victor Voronkov 2020-03-16 12:20:13 UTC
Verified on 4.4.0-0.ci-2020-03-11-095511

[core@master-0 ~]$ ps aux | grep /sbin/haproxy
USER         PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
1001        3297  0.0  0.2 146784 73120 ?        S    Mar12   0:08 /usr/sbin/haproxy -W -db -f /etc/haproxy/haproxy.cfg -p /var/lib/haproxy/run/haproxy.pid -x /var/lib/haproxy/run/haproxy.sock -sf 17 16
1001        3301  0.1  0.3 1317268 122652 ?      Sl   Mar12  10:44 /usr/sbin/haproxy -W -db -f /etc/haproxy/haproxy.cfg -p /var/lib/haproxy/run/haproxy.pid -x /var/lib/haproxy/run/haproxy.sock -sf 17 16

=== rebooting master-1:

cat /etc/haproxy/haproxy.cfg
...
backend masters
   option  httpchk GET /healthz HTTP/1.0
   option  log-health-checks
   balance roundrobin
   server master-2.ocp-edge-cluster.qe.lab.redhat.com. fd2e:6f44:5dd8:c956::112:6443 weight 1 verify none check check-ssl inter 3s fall 2 rise 3
   server master-0.ocp-edge-cluster.qe.lab.redhat.com. fd2e:6f44:5dd8:c956::150:6443 weight 1 verify none check check-ssl inter 3s fall 2 rise 3


[core@master-0 ~]$ ps aux | grep /sbin/haproxy
1001     1319149  0.0  0.2 146796 72944 ?        S    12:02   0:00 /usr/sbin/haproxy -W -db -f /etc/haproxy/haproxy.cfg -p /var/lib/haproxy/run/haproxy.pid -x /var/lib/haproxy/run/haproxy.sock -sf 38 35
1001     1319154  0.4  0.2 1314684 76856 ?       Sl   12:02   0:00 /usr/sbin/haproxy -W -db -f /etc/haproxy/haproxy.cfg -p /var/lib/haproxy/run/haproxy.pid -x /var/lib/haproxy/run/haproxy.sock -sf 38 35

=== master-1 rebooted:

[core@master-0 ~]$ ps aux | grep /sbin/haproxy
1001     1327960  0.0  0.2 146788 72788 ?        S    12:04   0:00 /usr/sbin/haproxy -W -db -f /etc/haproxy/haproxy.cfg -p /var/lib/haproxy/run/haproxy.pid -x /var/lib/haproxy/run/haproxy.sock -sf 61 58
1001     1327965  0.3  0.2 1314680 79340 ?       Sl   12:04   0:00 /usr/sbin/haproxy -W -db -f /etc/haproxy/haproxy.cfg -p /var/lib/haproxy/run/haproxy.pid -x /var/lib/haproxy/run/haproxy.sock -sf 61 58

[core@master-0 ~]$ tail -30f /etc/haproxy/haproxy.cfg 
  retries 3
  timeout http-request 10s
  timeout queue        1m
  timeout connect      10s
  timeout client       86400s
  timeout server       86400s
  timeout tunnel       86400s
...

Comment 5 errata-xmlrpc 2020-05-04 11:17:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.