Bug 1777395 - The minetest package is broken
Summary: The minetest package is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: minetest
Version: 30
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Aleksandra Fedorova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-27 15:12 UTC by ardjanve@gmail.com
Modified: 2020-01-05 00:44 UTC (History)
14 users (show)

Fixed In Version: minetest-5-3020191217165623.a5b0195c
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-05 00:44:09 UTC
Type: Bug


Attachments (Terms of Use)

Description ardjanve@gmail.com 2019-11-27 15:12:10 UTC
Description of problem: the minetest package is broken


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install fedora 30 xfce
2. dnf upgrade
3. dnf install minetest

Actual results:

[ard-jan@linux ~]$ sudo dnf install minetest
Last metadata expiration check: 1:29:15 ago on Wed 27 Nov 2019 02:33:54 PM CET.
Error: 
 Problem: conflicting requests
  - nothing provides libjsoncpp.so.19()(64bit) needed by minetest-5.0.0-1.module_f31+3570+17c32fe9.x86_64
(try to add '--skip-broken' to skip uninstallable packages)


Expected results:

installing minetest

Additional info:

Comment 1 Marek Blaha 2019-11-28 09:38:08 UTC
The requirements of minetest are broken, it requires older version of libjsoncpp.so than available:

# dnf repoquery --requires minetest
...
libjsoncpp.so.19()(64bit)
...

# dnf repoquery --provides jsoncpp
jsoncpp = 1.9.1-1.fc31
jsoncpp(x86-32) = 1.9.1-1.fc31
jsoncpp(x86-64) = 1.9.1-1.fc31
libjsoncpp.so.21
libjsoncpp.so.21()(64bit)

Reasigning to minetest.

Comment 2 Samuel Sieb 2019-12-01 00:18:08 UTC
Duplicate of Bug 1770568

Comment 3 Fedora Update System 2019-12-19 10:32:15 UTC
FEDORA-MODULAR-2019-99c9c79d4c has been submitted as an update to Fedora 30 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-99c9c79d4c

Comment 4 Fedora Update System 2019-12-20 17:35:18 UTC
minetest-5-3020191217165623.a5b0195c has been pushed to the Fedora 30 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-99c9c79d4c

Comment 5 Fedora Update System 2020-01-05 00:44:09 UTC
minetest-5-3020191217165623.a5b0195c has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.