Bug 177741 - Option "BookletPaperSize" systematically modified as a side effect when another option is modified
Summary: Option "BookletPaperSize" systematically modified as a side effect when anoth...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-13 17:19 UTC by Olivier C.
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 0.6.149-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 16:23:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier C. 2006-01-13 17:19:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I want to use a toshiba eSTUDIO650 photocopier/printer. I downloaded the ppd file : http://www.eid.toshiba.com/support/drivers/driverfiles/estudio550-650-810/gl1020-v21/Toshiba_GL1020_CUPS.gz

Every time I modify whatever driver option (for example I change the destination tray from 2 to 1) the option BookletPaperSize is modified to "A4"... Of course, I never asked that and I don't want to write a booklet ! I want that the option BookletPaperSize keeps its former value : "None".

In order to avoid printing in booklet mode I have to set the option BookletPaperSize to "None" whenever I change another option.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download the ppd file and install it with system-config-printer
2. Set the option BookletPaperSize to "None" 
3. Apply this change (the option "None" is now written in the /etc/cups/ppd/toshiba.ppd file)
4. Try to look at the options again : the BookletPaperSize shows the value "A4" which you did not ask for (however, the ppd file in /etc/cups/ppd is not modified)
5. Modify whatever option and apply it
6. Notice that the option BookletPaperSize has been changed to A4 and written in the ppd.

Expected Results:  The option BookletPaperSize should not be changed !

Additional info:

Comment 1 Tim Waugh 2006-01-17 16:14:22 UTC
This happens because, as you are in a locale that uses A4, system-config-printer
tries to 'correct' page size defaults to A4.  It does this by defaulting all
enums with 'A4' as an option to 'A4'. :-/


Comment 2 Tim Waugh 2006-01-17 16:23:27 UTC
Fixed in rawhide.  As a work-around you can use 'LC_ALL=C printconf' to launch it.

Comment 3 Olivier C. 2006-01-17 17:42:00 UTC
Hello, thank you for addressing this problem.
The work-around does not work for me (although all my locales are set to "C")
When I start "printconf", the GUI still displays "Booklet Paper Size : A4"
eventhough there is "DefaultBookletPaperSize: None" in the ppd file.

Comment 4 Tim Waugh 2006-01-18 08:55:32 UTC
Try 'LC_ALL=en_US.UTF-8' (the locale in which the paper size agrees with the
PPD's default).

Comment 5 Olivier C. 2006-01-18 10:01:35 UTC
I managed to make it work with the command : "LANG=en_US.UTF-8 printconf"

It doesn't work with "LC_ALL=en_US.UTF-8 printconf" nor with "LANG=C printconf".
Notice that "LC_ALL=en_US.UTF-8" sets all the LC_* variables, but not LANG.


Note You need to log in before you can comment on or make changes to this bug.