Bug 177750 - line wrapping broken before first interactive fork/exec
line wrapping broken before first interactive fork/exec
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-13 12:46 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 06:29:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-01-13 12:46:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
If you start a new bash session on a terminal (say bash --noprofile, bash --norc --noprofile doesn't exhibit the problem) and, after the prompt, start typing gibberish until the end of the line.  You'll see that it wraps around to the same line, not to the next line (tried xterm, gnome-terminal, VT1 and even over ssh).

Type ^C, enter, # comments, and it's still broken.  Type internal commands (e.g. type), and it still doesn't wrap to the next line.

Type a command that involves forking (say ls) and then the next command will line-wrap correctly when it gets to the end of a line.

The incorrect line wrapping is even worse if, after typing a long command line or searching back in history and hitting a very long line, you change your mind and hit ^U, or just try to edit that long line.  That's all nearly impossible to do.

Version-Release number of selected component (if applicable):
bash-3.1-2

How reproducible:
Always

Steps to Reproduce:
1.Start bash, or take a bash session that hasn't been used yet.
2.Type gibberish past the end of the line
3.Go on until you hit the end of the line again
4.Now try to go back and edit some of it
5.^C that
6.Run some command such as ls
7.Go back to 2

Actual Results:  2 and 3 wrap onto the same line, so 4 is nearly impossible.  After 7, it all works normally.

Expected Results:  Line wrapping before the first command should work like after it

Additional info:
Comment 2 Bill Crawford 2006-02-14 01:38:39 EST
Happening for me in xterm, too. I suspect the termcap changes, since doing a
reset in the xterm menu cures the problem (something that doesn't directly
affect bash, but still fixes it, implies something other than bash to be the
problem).

Also running "reset" in the xterm cures it. Otherwise it persists long past the
first line.
Comment 3 Bill Crawford 2006-02-14 01:40:06 EST
Still, if it's really fixedable upstream, ignore me.

Note You need to log in before you can comment on or make changes to this bug.