Bug 1777509 - Unable to delete Neutron Port from Pool
Summary: Unable to delete Neutron Port from Pool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Maysa Macedo
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks: 1777517
TreeView+ depends on / blocked
 
Reported: 2019-11-27 16:36 UTC by Maysa Macedo
Modified: 2020-05-04 11:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1777517 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:17:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 87 0 'None' closed Bug 1777509: Fix deletion of ports on a pool 2020-05-04 06:36:28 UTC
OpenStack gerrit 695182 0 'None' MERGED Fix deletion of ports on a pool 2020-05-04 06:36:28 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:18:16 UTC

Description Maysa Macedo 2019-11-27 16:36:53 UTC
Description of problem:

When deleting ports from a pool an update of a dict that is being iterated is wrongly performed causing the following exception:

2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/handlers/logging.py", line 37, in __call__
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging self._handler(event)
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/handlers/retry.py", line 78, in __call__
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging self._handler(event)
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/handlers/k8s_base.py", line 77, in __call__
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging self.on_deleted(obj)
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/handlers/namespace.py", line 159, in on_deleted
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging self._drv_vif_pool.delete_network_pools(net_crd['spec']['netId'])
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/drivers/vif_pool.py", line 1108, in delete_network_pools
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging vif_drv.delete_network_pools(net_id)
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging File "/usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/drivers/vif_pool.py", line 1017, in delete_network_pools
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging for pool_key, ports in self._available_ports_pools.items():
2019-11-19 18:15:13.259 1 ERROR kuryr_kubernetes.handlers.logging RuntimeError: dictionary changed size during iteration



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run OCP conformance tests
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Itzik Brown 2020-01-27 14:20:57 UTC
Checked with 4.4.0-0.nightly-2020-01-24-141203
Ran conformance tests - Didn't see the error mentioned.

Comment 4 errata-xmlrpc 2020-05-04 11:17:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.