Bug 1777518 - Port NotFound exception wrongly cause Kuryr-Controller restart
Summary: Port NotFound exception wrongly cause Kuryr-Controller restart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Maysa Macedo
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks: 1777732
TreeView+ depends on / blocked
 
Reported: 2019-11-27 17:20 UTC by Maysa Macedo
Modified: 2020-05-04 11:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1777732 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:17:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 90 0 'None' closed Bug 1777518: Handle not found subport on Trunk 2020-06-25 07:30:40 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:18:13 UTC

Description Maysa Macedo 2019-11-27 17:20:47 UTC
Description of problem:

In case a namespace is created-deleted-created, the last namespace creation event notices that a KuryrNet CRD still exists, as it can take a while for the previous deletion event to complete and will trigger again another deletion causing the following NotFound SubPort on Trunk error:

namespace_subnet [-] Port d93da41a-4e9a-4140-ab08-a26bd10d775f is in DOWN status but still associated to a trunk. This should not happen. Trying to delete it from the t
runk.: Conflict: Port d93da41a-4e9a-4140-ab08-a26bd10d775f is currently a subport for trunk e69bb33f-2efc-45c7-9bfd-cd68980b5f28.
2019-11-25 20:35:44.577 1 DEBUG kuryr_kubernetes.controller.managers.health [-] Kuryr Controller Liveness verified. liveness_status /usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/managers/health.py:111
2019-11-25 20:35:44.577 1 INFO werkzeug [-] 192.168.99.29 - - [25/Nov/2019 20:35:44] "GET /alive HTTP/1.1" 200 -
2019-11-25 20:35:44.607 1 DEBUG neutronclient.v2_0.client [-] Error message: {"NeutronError": {"message": "Port d93da41a-4e9a-4140-ab08-a26bd10d775f is currently a subport for trunk e69bb33f-2efc-45c7-9bfd-cd68980b5f28.", "type": "PortInU
seAsSubPort", "detail": ""}} _handle_fault_response /usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py:259
2019-11-25 20:35:44.607 1 WARNING kuryr_kubernetes.controller.drivers.namespace_subnet [-] Port d93da41a-4e9a-4140-ab08-a26bd10d775f is in DOWN status but still associated to a trunk. This should not happen. Trying to delete it from the t
runk.: Conflict: Port d93da41a-4e9a-4140-ab08-a26bd10d775f is currently a subport for trunk e69bb33f-2efc-45c7-9bfd-cd68980b5f28.
2019-11-25 20:35:44.672 1 DEBUG neutronclient.v2_0.client [-] Error message: {"NeutronError": {"message": "SubPort on trunk e69bb33f-2efc-45c7-9bfd-cd68980b5f28 with parent port d93da41a-4e9a-4140-ab08-a26bd10d775f could not be found.", "
type": "SubPortNotFound", "detail": ""}} _handle_fault_response /usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py:259
2019-11-25 20:35:44.673 1 ERROR kuryr_kubernetes.handlers.retry [-] Report handler unhealthy NamespaceHandler: NotFound: SubPort on trunk e69bb33f-2efc-45c7-9bfd-cd68980b5f28 with parent port d93da41a-4e9a-4140-ab08-a26bd10d775f could not
 be found.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Itzik Brown 2020-01-27 14:51:36 UTC
Checked with 4.4.0-0.nightly-2020-01-24-141203
Created/Deleted/Created the same project.
Also ran the conformance tests and haven't  seen the errors.

Comment 4 errata-xmlrpc 2020-05-04 11:17:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.