Bug 177763 - Segfault in ghostscript 64-bit; gs707, gs815, or gs850
Segfault in ghostscript 64-bit; gs707, gs815, or gs850
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-01-13 14:36 EST by Rick Richardson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 8.15.3-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 13:18:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2006-01-13 14:36:17 EST
$ gs707 -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sPAPERSIZE=letter -g5100x6600
-r600x600 -sDEVICE=bitcmyk -sOutputFile=xxx /tmp/icc.usecie.ps /tmp/icc.crd.ps
/tmp/icc.selcrd.ps testpage-ubuntu.ps
Segmentation fault (core dumped)

$ gs815 -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sPAPERSIZE=letter -g5100x6600
-r600x600 -sDEVICE=bitcmyk -sOutputFile=xxx /tmp/icc.usecie.ps /tmp/icc.crd.ps
/tmp/icc.selcrd.ps testpage-ubuntu.ps
Segmentation fault (core dumped)

$ gs850 -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sPAPERSIZE=letter -g5100x6600
-r600x600 -sDEVICE=bitcmyk -sOutputFile=xxx /tmp/icc.usecie.ps /tmp/icc.crd.ps
/tmp/icc.selcrd.ps testpage-ubuntu.ps
Segmentation fault (core dumped)

$ CC="cc -m32" ./configure --without-x;  make ...

$ gs850_32 -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sPAPERSIZE=letter -g5100x6600
-r600x600 -sDEVICE=bitcmyk -sOutputFile=xxx /tmp/icc.usecie.ps /tmp/icc.crd.ps
/tmp/icc.selcrd.ps testpage-ubuntu.ps
$

Yep, something wrong with 64-bit.

Get files from: http://bugs.ghostscript.com/show_bug.cgi?id=688486
Comment 1 Rick Richardson 2006-01-23 04:36:56 EST
Fix is:

http://ghostscript.com/pipermail/gs-cvs/2005-August/005686.html

Unverified.  It is in GS707.

Comment 2 Tim Waugh 2006-01-23 05:13:27 EST
This is on the AFPL-licensed trunk though -- we need the author to apply it to
the GPL branch. :-/
Comment 3 Rick Richardson 2006-01-23 07:06:45 EST
Then don't compile gs in 64-bit.  fc1/fc2/Fc3/fc4/fc5 etc. should be compiled in
32-bit only, since 64-bit has lots of problems and you will not pay to get them
fixed.
Comment 5 Fedora Update System 2007-01-18 12:21:30 EST
Fixed in update: ghostscript-8.15.3-3.fc6

Note You need to log in before you can comment on or make changes to this bug.