Bug 1777646 - Retire tortoisehg in Fedora 32+
Summary: Retire tortoisehg in Fedora 32+
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tortoisehg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mads Kiilerich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1739050 (view as bug list)
Depends On:
Blocks: PYTHON2_EOL PY2REMOVAL F31_PY2REMOVAL
TreeView+ depends on / blocked
 
Reported: 2019-11-28 01:04 UTC by Miro Hrončok
Modified: 2019-12-02 01:04 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-02 01:04:33 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2019-11-28 01:04:27 UTC
In line with the Retire Python 2 Fedora change [0], all (sub)packages of tortoisehg were marked for removal.

There was no FESCo exception for this package.

Please retire your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31/30/29, removing packages from a released Fedora branch is forbidden and out of scope of this request.

If there is no objection in a week, we will retire the package for you.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

This text is automated. We are sorry if you already communicated with us about this in another place.

[0] https://fedoraproject.org/wiki/Changes/RetirePython2

Comment 1 Miro Hrončok 2019-11-28 01:23:34 UTC
*** Bug 1739050 has been marked as a duplicate of this bug. ***

Comment 2 Mads Kiilerich 2019-11-28 11:41:13 UTC
I will update TortoiseHg to python3 as soon as the dependencies are available. It should not be retired. The Mercurial package should either have active ownership, or it should be handed over to someone else.

Comment 3 Miro Hrončok 2019-11-28 11:44:30 UTC
There is mercurial-py3-5.2-1.fc32.

Comment 4 Mads Kiilerich 2019-11-28 12:44:03 UTC
Ok, it just came. Thanks.
https://bodhi.fedoraproject.org/updates/FEDORA-2019-c6874b8eb3 with hgview passed. I will test and move on to tortoisehg.

Comment 5 Miro Hrončok 2019-12-02 01:04:33 UTC
Thank You.


Note You need to log in before you can comment on or make changes to this bug.