Bug 1777837 - [IPI][Baremetal] Infra pods reserve too many resources
Summary: [IPI][Baremetal] Infra pods reserve too many resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: 4.4.0
Assignee: Yossi Boaron
QA Contact: Eldar Weiss
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-28 12:23 UTC by Yossi Boaron
Modified: 2020-05-04 11:18 UTC (History)
5 users (show)

Fixed In Version: 4.4
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:17:52 UTC
Target Upstream Version:
yboaron: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1295 'None' closed Bug 1777837: BAREMETAL- decrease infra pods resources 2020-05-03 07:42:25 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:18:13 UTC

Description Yossi Boaron 2019-11-28 12:23:35 UTC
Description of problem:

Duplication of [1] for Baremetal case

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1772440

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Raviv Bar-Tal 2020-02-18 13:35:41 UTC
The duplicated BZ is also for 4.4..0 release,
Do we still need this one? or can we close it as duplicate?

https://bugzilla.redhat.com/show_bug.cgi?id=1772440

Comment 4 Yossi Boaron 2020-02-27 07:50:26 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1772440 is for OSP case and this bug is for baremetal, so no duplication.

Comment 5 Eldar Weiss 2020-03-16 11:55:10 UTC
Problem is resolved.

How to verify:

1. login to a baremetal server that has OCP 4.4 installed
2. login to the provision host by using: ssh kni@provisionhost
3. view pods by using: oc get pods -n openshift-kni-infra
4. for each type of pod, check memory and CPU by using:

oc get pod  -n   openshift-kni-infra keepalived-master-0.victor-cluster.qe.lab.redhat.com -o yaml | egrep "memory|cpu"

see that the above details fit the limit for each pod in the above yaml.

Comment 7 errata-xmlrpc 2020-05-04 11:17:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.