Bug 1777966 - Registered hosts from the GUI are created under the default namespace instead of openshift-machine-api
Summary: Registered hosts from the GUI are created under the default namespace instead...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.z
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-28 20:07 UTC by Udi
Modified: 2020-05-26 16:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-26 16:50:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3881 None closed Bug 1777966: Use HrefNavItem for BMH nav link 2020-06-18 13:23:59 UTC
Red Hat Product Errata RHBA-2020:2180 None None None 2020-05-26 16:50:53 UTC

Description Udi 2019-11-28 20:07:05 UTC
Description of problem:
I registered another worker using the GUI, and it never got passed the "powering up" stage. From the CLI I could see that it was registered in the "default" namespace:

$ oc get baremetalhosts --all-namespaces
NAMESPACE               NAME         
default                 worker-1

This problem, in turn, also makes it impossible to delete the host from the GUI (the "delete" command is not available)


Version-Release number of selected component (if applicable):
4.4.0-0.ci-2019-11-28-063411


How reproducible:
100%


Steps to Reproduce:
1. Register a node from the GUI

Comment 1 Jiri Tomasek 2019-12-02 10:12:32 UTC
The host is registered in currently active project as expected. It seems that a host has to be created in openshift-machine-api to be acted upon by MAO or BMO (?). When user goes to Machines page, the UI switches the namespace to openshift-machine-api. We can do the same with baremetal hosts page, but it doesn't prevent user from subseguently change the namespace (project) to something different. Same applies to CLI. The exact same issue can be observed on Machines, so I guess that's expected but not very user friendly.

Comment 2 Udi 2019-12-03 07:54:20 UTC
Allowing the user to register the hosts in the wrong namespace makes no sense. Can we just always run the registration in the right namespace? The same goes for reading the hosts - regardless of which namespace is currently selected in the UI, we should get the data from openshift-machine-api. This should be fixed in 4.3 as well.

Comment 5 Yanping Zhang 2020-05-21 06:48:02 UTC
Checked on 4.4 cluster with payload: 4.4.0-0.nightly-2020-05-18-164758
Goto "Bare Metal Hosts" page, it will switch to namespace "openshift-machine-api" by default, and adding host from console will also create host in namespace "openshift-machine-api" by default now.
The bug is fixed.

Comment 8 errata-xmlrpc 2020-05-26 16:50:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2180


Note You need to log in before you can comment on or make changes to this bug.