Bug 177808 - Bash not picking up customizations from /etc/inputrc
Bash not picking up customizations from /etc/inputrc
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-14 09:12 EST by Steven Usdansky
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 05:48:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2006-01-14 09:12:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
I've been adding the following lines to the end of my /etc/inputrc file since before FC-1 came out, and they have always worked as expected. I type the first letter of a command, hit the up arrow key, and the most recent command in my history list starting with that letter appears on the command line. Additional presses of the up arrow take me farther back in the history list (to commands starting with the same first letter).

 # for history list navigation with up/down arrows
 "\M-[A":history-search-backward
 "\M-[B":history-search-forward

It worked fine in bash-3.0-36 (which I just reinstalled). It does not work at all in bash 3.1-5.

Version-Release number of selected component (if applicable):
bash-3.1-5

How reproducible:
Always

Steps to Reproduce:
1. Upgrade bash from 3.0-36 to 3.1-5
2. add the above three lines to /etc/inputrc
3. type the command "ls" and press the enter key
4. type the command "cat /etc/inputrc" and press the enter key
5. type the letter "l" and press the up-arrow key
  

Actual Results:  The command line shows "cat /etc/inputrc"

Expected Results:  The command line shows "ls"

Additional info:
Comment 1 Tim Waugh 2006-01-17 05:34:53 EST
FWIW, '"\e[A": history-search-backward' works.

I'll ask about this upstream.
Comment 3 Steven Usdansky 2006-01-18 07:31:57 EST
Thanks, Tim. I've made the changes to my inputrc file (but still don't
understand the change from '\M-' to '\e'

Note You need to log in before you can comment on or make changes to this bug.