Bug 177813 - flex breaks the compilation of Wine
flex breaks the compilation of Wine
Status: CLOSED DUPLICATE of bug 177830
Product: Fedora
Classification: Fedora
Component: flex (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-14 12:53 EST by Michael Stefaniuc
Modified: 2015-05-04 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 11:25:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stefaniuc 2006-01-14 12:53:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
With the flex-2.5.4a-35.fc4 errata i get following error while compiling Wine:
gcc -g -O2 -o widl client.o hash.o header.o proxy.o server.o typegen.o typelib.o utils.o widl.o write_msft.o parser.tab.o lex.yy.o -L../../libs -lwpp -lwine_port -lfl
../../libs/libwpp.a(lex.yy.o)(.text+0x5e8): In function `_yy_dummy_uses_of_static_functions_b2f4_517d_02ff_b30c_3e5a_47d7_aaa3_3b5d_':
/j/wine/build/wine/libs/wpp/lex.yy.c:3357: multiple definition of `_yy_dummy_uses_of_static_functions_b2f4_517d_02ff_b30c_3e5a_47d7_aaa3_3b5d_'
lex.yy.o(.text+0x550):/j/wine/build/wine/tools/widl/lex.yy.c:1796: first defined here
collect2: ld returned 1 exit status
make[2]: *** [widl] Error 1

Downgrading flex back to flex-2.5.4a-34 fixes the problem.

Version-Release number of selected component (if applicable):
flex-2.5.4a-35.fc4

How reproducible:
Always

Steps to Reproduce:
1. Get Wine from http://www.winehq.org/ (i'm using todays CVS)
2. unpack and ./configure
3. make
  

Actual Results:  Compilation stopped while linking widl

Expected Results:  Compilation should have finished successfully

Additional info:
Comment 1 Fedora Update System 2006-01-18 10:30:53 EST
From User-Agent: XML-RPC

flex-2.5.4a-36.fc4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 2 Petr Machata 2006-01-18 11:25:07 EST

*** This bug has been marked as a duplicate of 177830 ***
Comment 3 Andreas Bierfert 2006-01-19 18:22:05 EST
How long will it take till this is pushed to updates? I need this to push new
wine through the fe buildsys :)
Comment 4 Petr Machata 2006-01-20 09:42:54 EST
It is already pushed for final, so hopefully in a couple of hours. There is
fixed version in testing already, if it is the option for you.

Note You need to log in before you can comment on or make changes to this bug.