Bug 177820 - beagled doesn't start
beagled doesn't start
Status: CLOSED DUPLICATE of bug 179228
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-14 16:51 EST by Bastien Nocera
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 11:10:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-01-14 16:51:39 EST
beagle-0.1.4-3

<snip>
Error: Unhandled exception thrown.  Exiting immediately.
Debug: Will index mbox /home/hadess/.evolution/mail/local/Old.sbd/Linux-Arverne
Debug: Overall percent is 0
Error: System.DllNotFoundException: glibsharpglue
in (wrapper managed-to-native) Evolution.GLibUtil:gtksharp_slist_get_data (intptr)
in [0x0002b] (at
/usr/src/build/678545-i386/BUILD/evolution-sharp-0.10.2/evolution/src/CalUtil.cs:18)
Evolution.CalUtil:GLibSListToCalCompArray (IntPtr slist, Evolution.Cal ecal)
in [0x00009] (at
/usr/src/build/678545-i386/BUILD/evolution-sharp-0.10.2/evolution/src/CalUtil.cs:142)
Evolution.CalUtil:CalCompFromICal (IntPtr ical_objects, Evolution.Cal ecal)
in <0x0004b>
Beagle.Daemon.EvolutionDataServerQueryable.CalContainer:OnObjectsAdded
(System.Object o, Evolution.ObjectsAddedArgs args)
in (wrapper delegate-invoke)
System.MulticastDelegate:invoke_void_object_ObjectsAddedArgs
(object,Evolution.ObjectsAddedArgs)
in [0x0007e] (at
/usr/src/build/678545-i386/BUILD/evolution-sharp-0.10.2/evolution/generated/CalView.cs:240)
Evolution.CalView:ObjectsAddedSignalCallback (IntPtr arg0, IntPtr arg1, IntPtr gch)
in (wrapper native-to-managed) Evolution.CalView:ObjectsAddedSignalCallback
(intptr,intptr,intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00007> Gtk.Application:Run ()
in <0x004f5> Beagle.Daemon.BeagleDaemon:DoMain (System.String[] args)
in <0x00014> Beagle.Daemon.BeagleDaemon:Main (System.String[] args)
Debug: Will index mbox /home/hadess/.evolution/mail/local/Old.sbd/5th Toe

** (beagled:2455): WARNING **: FIXME: wait for completion unimplemented

** ERROR **: EnterCriticalSection: EnterCriticalSection failed: Invalid
argumentaborting...
Trace/breakpoint trap
Comment 1 Andy Burns 2006-02-04 12:42:50 EST
Different reason, same result :-(

Name   : beagle
Arch   : x86_64
Version: 0.2.1
Release: 1

$ mono --debug /usr/lib64/beagle/Search.exe

Unhandled Exception: System.DllNotFoundException: libbeagleuiglue.so
in (wrapper managed-to-native) Search.Entry:search_entry_new ()
in <0x00075> Search.Entry:.ctor ()
in <0x00317> Search.MainWindow:.ctor ()
in <0x000cf> Search.MainWindow:Main (System.String[] args)

# find / -name *beagle*.so
/usr/lib64/beagle/libbeagleuiglue.so
/usr/lib64/beagle/libbeagleglue.so

Comment 2 Andy Burns 2006-02-04 12:47:57 EST
OK, I was short-circuiting too much there, I had just re-run the command from
bash with the same args I saw from "ps -efa" but that didn't set the path properly.

if I change into /usr/lib64/beagle and do "mono Start.exe" 
or run it as "/usr/bin/beagle-search"
it just hangs the same as it does when started from Gnome :-(

Comment 3 Christopher Aillon 2006-02-09 11:10:49 EST
It turns out this is a kernel issue.

*** This bug has been marked as a duplicate of 179228 ***

Note You need to log in before you can comment on or make changes to this bug.