Bug 177824 - gdm - /etc/X11/gdm/PreSession/Default greps through a non-existent file
gdm - /etc/X11/gdm/PreSession/Default greps through a non-existent file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-14 18:59 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 15:29:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-01-14 18:59:21 EST
Description of problem:

/etc/X11/gdm/PreSession/Default in few places does
 
   grep <something> /etc/X11/gdm/gdm.conf | sed 's/..../..../'

The problem is that /etc/X11/gdm/gdm.conf vanished recently and
only /etc/X11/gdm/custom.conf _may_ exist.  Besides should not PostLogin,
PostSession and PreSession be relocated for consistency to
/usr/share/gdm/config/ direcory as well?  At least in PostLogin case it
is clear that sysadmin may create something customized there.

BTW - this 'grep ... | sed ...' construct is not really needed and can
be simplified to:

   
   sed '/<whatever>/s/..../..../' <appropriate config file>

   
Version-Release number of selected component (if applicable):
gdm-2.13.0.4-3
Comment 1 Matthias Clasen 2006-03-01 15:29:31 EST
I believe this is obsolete since gdm has a new configuration mechanism now.
No greps in PreSession/Default anymore

Note You need to log in before you can comment on or make changes to this bug.