Bug 177843 - unicode support is poor in vte
Summary: unicode support is poor in vte
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2006-01-15 13:12 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 17:47:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 158200 None None None Never

Description Need Real Name 2006-01-15 13:13:27 UTC
(Ack. I broke bugzilla again. Will file a bug..)

If I sftp to a machine, and use
 mkdir Ãpache
then realise my mistake, press backspace six times, so that it reads:
 mkdir Apache
then press enter. a directory called "Apache" is not created.

$ ls -tr1|tail -1|cat -v
M-CApache

$ echo $LANG
de_AT.UTF-8

Comment 1 Tomas Mraz 2006-01-16 10:26:45 UTC
I'm sorry but I cannot reproduce your problem at all. Backspace works normally
here. What are the $LANG settings on both client and server machine? What
terminal application do you use?

This is most probably some misconfiguration on your setup or there is bug in the
terminal application used.


Comment 2 Need Real Name 2006-01-16 11:52:49 UTC
Both client and server are de_AT.UTF-8.
I am using gnome-terminal.

Comment 3 Tomas Mraz 2006-01-16 12:45:54 UTC
Reproduceable in gnome-terminal only (not xterm or konsole) -> reassign.


Comment 4 Need Real Name 2006-03-15 10:42:49 UTC
Still broken.

Comment 5 Ray Strode [halfline] 2006-03-15 17:18:38 UTC
Is this broken in FC4 only, or rawhide too?  I have a really vague memory of a
bug like this getting fixed some time ago.

If it's already fixed in rawhide, maybe we can do an fc4 update.

Comment 6 Need Real Name 2006-03-15 18:18:09 UTC
Ugh. It's still broken in Rawhide too. Here are some umlauts to test! öäü

Comment 7 Matthias Clasen 2006-08-02 17:43:28 UTC
Fix is in upstream cvs, we should make sure it gets into FC6

Comment 8 Matthias Clasen 2006-08-02 17:47:49 UTC
Fixed in 0.13.5-1.fc6


Note You need to log in before you can comment on or make changes to this bug.