Bug 177851 - cannot hibernate completely
cannot hibernate completely
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 178157 (view as bug list)
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2006-01-15 12:19 EST by Jesse Keating
Modified: 2015-01-04 17:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 03:03:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg w/ kernel 2.6.15-1.1915_FC5 (19.59 KB, text/plain)
2006-02-08 21:25 EST, Jim Cornette
no flags Details
dmesg with error message from a successful suspend/resume (18.09 KB, text/plain)
2006-02-25 17:58 EST, Ricky Ng-Adam
no flags Details

  None (edit)
Description Jesse Keating 2006-01-15 12:19:39 EST
Systme will start to hibernate, but will bounce out of it and resume. 
Presumably because some process can't completely be moved into swap.

[jkeating@ender ~]$ rpm -q gnome-power-manager kernel
gnome-power-manager-0.3.3-0.cvs.20060106
kernel-2.6.15-1.1853_FC5

Message from syslogd@ender at Sun Jan 15 12:22:17 2006 ...
ender kernel:  [<c01faa5b>] acpi_ut_allocate_object_desc_dbg+0x13/0x49    <0>
[<c01fa8ef>] acpi_ut_create_internal_object_dbg+0x13/0x68

Message from syslogd@ender at Sun Jan 15 12:22:17 2006 ...
ender kernel:  [<c01546b0>] kmem_cache_alloc+0x1b/0x79    <0> [<c01e6484>]
acpi_os_acquire_object+0xb/0x3c

Message from syslogd@ender at Sun Jan 15 12:22:17 2006 ...
ender kernel:  [<c01f6fa6>] acpi_rs_set_srs_method_data+0x3d/0xb7    <0>
[<c0154422>] cache_alloc_debugcheck_after+0xb8/0xea

Message from syslogd@ender at Sun Jan 15 12:22:17 2006 ...
ender kernel:  [<c01fe13c>] acpi_pci_link_set+0x3b/0x17c    <0> [<c01fe204>]
acpi_pci_link_set+0x103/0x17c

Message from syslogd@ender at Sun Jan 15 12:22:20 2006 ...
ender kernel:  [<c01fe6ad>] irqrouter_resume+0x1e/0x3c    <0> [<c022bce7>]
__sysdev_resume+0x11/0x53

Message from syslogd@ender at Sun Jan 15 12:22:20 2006 ...
ender kernel:  [<c022bef0>] sysdev_resume+0x16/0x47    <0> [<c022fbf0>]
device_power_up+0x5/0xa

Message from syslogd@ender at Sun Jan 15 12:22:20 2006 ...
ender kernel:  [<c01360e9>] swsusp_suspend+0x6b/0x85    <0> [<c01369a9>]
pm_suspend_disk+0x4f/0xbe

Message from syslogd@ender at Sun Jan 15 12:22:20 2006 ...
ender kernel:  [<c013503e>] enter_state+0x47/0xaa    <0> [<c01351ad>]
state_store+0x88/0x94

Message from syslogd@ender at Sun Jan 15 12:22:21 2006 ...
ender kernel:  [<c0135125>] state_store+0x0/0x94    <0> [<c018a73a>]
subsys_attr_store+0x1e/0x22

Message from syslogd@ender at Sun Jan 15 12:22:21 2006 ...
ender kernel:  [<c018a90b>] flush_write_buffer+0x1d/0x21    <0> [<c018a960>]
sysfs_write_file+0x51/0x74

Message from syslogd@ender at Sun Jan 15 12:22:21 2006 ...
ender kernel:  [<c018a90f>] sysfs_write_file+0x0/0x74    <0> [<c0156d59>]
vfs_write+0xa1/0x140

Message from syslogd@ender at Sun Jan 15 12:22:21 2006 ...
ender kernel:  [<c0156e97>] sys_write+0x3c/0x63    <0> [<c0102c4d>]
syscall_call+0x7/0xb
Comment 1 Dave Jones 2006-01-17 00:48:03 EST
any chance you can run 'dmesg' and get the full oops ?
Comment 2 Jesse Keating 2006-01-17 00:56:37 EST
Stopping tasks:
===============================================================================================================================|
Shrinking memory... done (184202 pages freed)
pnp: Device 00:0a disabled.
pnp: Device 00:09 disabled.
eth1: Going into suspend...
ACPI: PCI interrupt for device 0000:02:02.0 disabled
ACPI: PCI interrupt for device 0000:02:01.0 disabled
ACPI: PCI interrupt for device 0000:02:00.1 disabled
ACPI: PCI interrupt for device 0000:02:00.0 disabled
ACPI: PCI interrupt for device 0000:00:1f.6 disabled
ACPI: PCI interrupt for device 0000:00:1f.5 disabled
ACPI: PCI interrupt for device 0000:00:1d.7 disabled
ACPI: PCI interrupt for device 0000:00:1d.2 disabled
ACPI: PCI interrupt for device 0000:00:1d.1 disabled
ACPI: PCI interrupt for device 0000:00:1d.0 disabled
PM: snapshotting memory.
swsusp: Saving Highmem
................................<7>swsusp: critical section:
swsusp: Need to copy 60938 pages
swsusp: pages needed: 60938 + 179 + 1024, free: 191439
swsusp: available memory: 168436 pages
alloc_pagedir(): nr_pages = 60938
swsusp: critical section/: done (60938 pages copied)
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
swsusp: Restoring Highmem
Debug: sleeping function called from invalid context at mm/slab.c:2528
in_atomic():0, irqs_disabled():1
 [<c01546b0>] kmem_cache_alloc+0x1b/0x79    <0> [<c01e6484>]
acpi_os_acquire_object+0xb/0x3c
 [<c01faa5b>] acpi_ut_allocate_object_desc_dbg+0x13/0x49    <0> [<c01fa8ef>]
acpi_ut_create_internal_object_dbg+0x13/0x68
 [<c01f6fa6>] acpi_rs_set_srs_method_data+0x3d/0xb7    <0> [<c0154422>]
cache_alloc_debugcheck_after+0xb8/0xea
 [<c01fe13c>] acpi_pci_link_set+0x3b/0x17c    <0> [<c01fe204>]
acpi_pci_link_set+0x103/0x17c
 [<c01fe6ad>] irqrouter_resume+0x1e/0x3c    <0> [<c022bce7>]
__sysdev_resume+0x11/0x53
 [<c022bef0>] sysdev_resume+0x16/0x47    <0> [<c022fbf0>] device_power_up+0x5/0xa
 [<c01360e9>] swsusp_suspend+0x6b/0x85    <0> [<c01369a9>] pm_suspend_disk+0x4f/0xbe
 [<c013503e>] enter_state+0x47/0xaa    <0> [<c01351ad>] state_store+0x88/0x94
 [<c0135125>] state_store+0x0/0x94    <0> [<c018a73a>] subsys_attr_store+0x1e/0x22
 [<c018a90b>] flush_write_buffer+0x1d/0x21    <0> [<c018a960>]
sysfs_write_file+0x51/0x74
 [<c018a90f>] sysfs_write_file+0x0/0x74    <0> [<c0156d59>] vfs_write+0xa1/0x140
 [<c0156e97>] sys_write+0x3c/0x63    <0> [<c0102c4d>] syscall_call+0x7/0xb
Comment 3 Dave Jones 2006-01-17 01:19:03 EST
hrmph.  I fixed one variant of that backtrace in 2.6.15, but this one is
slightly different, and more tricky to fix. I've poked upstream to have a think
about it.

That's only secondary though to your actual problem.  There's nothing in the
messages about *why* it decided to resume instantly. Very annoying.
Comment 4 Vitaly A. Sorokin 2006-01-29 02:06:58 EST
I have the same exception as Jesse, and plenty ACPI errors also on my IBM
ThinkPad X21. Will submit logs a but later.
Comment 5 Jeremy Katz 2006-02-08 11:12:04 EST
*** Bug 178157 has been marked as a duplicate of this bug. ***
Comment 6 Jim Cornette 2006-02-08 21:25:02 EST
Created attachment 124420 [details]
dmesg w/ kernel 2.6.15-1.1915_FC5

/sbin/lspci
00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin
IV/V/V+]
00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus
Controller
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
Comment 7 Ricky Ng-Adam 2006-02-25 17:58:20 EST
Created attachment 125262 [details]
dmesg with error message from a successful suspend/resume

I had a problem with hibernate in bug #178157, but FC5test3 works fine and I'm
able to "Suspend" (Hibernate) and resume correctly.

However, my dmesg shows the same error as reported here:

Debug: sleeping function called from invalid context at mm/slab.c:2700
Comment 8 Dave Jones 2006-03-02 03:03:36 EST
ok, the debug spew should be gone in the kernel now building
(kernel-2.6.15-1.2008_FC5).  It won't make tomorrows rawhide, but you can grab
it early from http://people.redhat.com/davej/kernels/Fedora/devel once it's done
building.

Note You need to log in before you can comment on or make changes to this bug.