Bug 1778613 - Java latest Istag does not link to the version correctly on Imagestream detail page.
Summary: Java latest Istag does not link to the version correctly on Imagestream detai...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-02 08:18 UTC by XiaochuanWang
Modified: 2020-05-13 21:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the java imagestream sample from the EAP team had an incorrect imagestreamtag defintion for the java 11 image Consequence: that imagestreamtag could not be inspected from the openshift console Fix: correct the upstream EAP imagestreamtag specification for java 11 and pull it down into the openshift samples Result: the java 11 imagestreamtag can now be properly inspected from the openshift console
Clone Of:
Environment:
Last Closed: 2020-05-13 21:53:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
See java:java:11 in column From for the latest tag (12.57 KB, image/png)
2019-12-02 08:18 UTC, XiaochuanWang
no flags Details
Non-existed url for java:java:11 Istag (25.52 KB, image/png)
2019-12-02 08:20 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github jboss-container-images openjdk pull 103 'None' 'open' 'Java''s tag name should contain only version' 2020-06-18 15:23:06 UTC
Github openshift cluster-samples-operator pull 210 None None None 2020-06-18 15:23:06 UTC
Github openshift library pull 198 None None None 2020-06-18 15:23:06 UTC
Red Hat Issue Tracker CLOUD-3449 Major Resolved openjdk imagestream definition breaks openshift console 2020-06-18 15:23:05 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:53:30 UTC

Description XiaochuanWang 2019-12-02 08:18:57 UTC
Created attachment 1641278 [details]
See java:java:11 in column From for the latest tag

Description of problem:
The "Latest" Istag in "From" column on Java Imagestream detail page does not link correctly to the version (Java 11)

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-29-051144

How reproducible:
Always

Steps to Reproduce:
1. Go to Image Stream page of project "Openshift", choose "java"
2. On Java detail page, scroll down the page check the imagestream form (Please refer to the screenshot.)
3. Check and click the column "From" for the tag latest.

Actual results:
The link for latest tag is incorrect which is "java:java:11". 
"java:java:11" page will display "Error Loading : ImageStreamTags must be retrieved with <name>:<tag>" (Please see the screenshot)

Expected results:
Should link correctly to Java:11.

Additional info:

Comment 1 XiaochuanWang 2019-12-02 08:20:34 UTC
Created attachment 1641279 [details]
Non-existed url for java:java:11 Istag

Comment 2 Jakub Hadvig 2019-12-02 12:30:41 UTC
This is not a Management Console issue, but incorrect value for the java's image stream that
cluster-sample-operator is taking care of.

When the latest tag from.name value is set from 'java:11' to '11' the link is displayed and linked correctly.

Comment 3 Jakub Hadvig 2019-12-02 12:41:41 UTC
PR for cluster-sample-operator : https://github.com/openshift/cluster-samples-operator/pull/201

Comment 4 Gabe Montero 2019-12-02 17:21:26 UTC
This is technically a jboss bug in how they define the openjdk imagestreams

I'm pursuing the best path for transferring this work to them (jboss jira, etc.)

Comment 5 Gabe Montero 2019-12-02 19:07:22 UTC
have linked the jboss jira issue and PR from jakub in this bug 

re-moving to POST while we wait on JBoss

Comment 6 Gabe Montero 2019-12-11 18:53:32 UTC
Moving back to post ... need the samples operator change

Comment 9 XiuJuan Wang 2020-01-06 02:27:28 UTC
The issue has fixed in 4.4.0-0.nightly-2020-01-04-014624 version.

Comment 11 errata-xmlrpc 2020-05-13 21:53:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.