Bug 17788 - Startupposition conflicts with portmap
Summary: Startupposition conflicts with portmap
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-22 14:27 UTC by Enrico Scholz
Modified: 2016-11-24 15:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 09:10:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-09-22 14:27:55 UTC
syslog makes a connection to localhost, port 111 at startup and waits until
it's established or a timeout occurs.  That's why my startup hangs around 5
minutes at this point.

I am using a @host-entry in /etc/syslog.conf and linux-2.4.0-test8. The
connection attempt can be seen with strace.


I suggest to swap the syslog (12) and portmap (13) startup-positions, so
portmap runs before syslog will be executed.

Comment 1 Bill Nottingham 2000-12-11 22:30:24 UTC
It's a change in the kernel's socket behavior.  glibc's RPC stuff
needs tweaked. Alternatively, don't define an NIS domainname
until you run ypbind (this is what the rawhide initscripts and
ypbind will do.)

Assigning to glibc.

Comment 2 Ulrich Drepper 2003-04-22 00:44:30 UTC
Is this still an issue in RHL9?  I very much doubt it.  Please report so that I
can close the bug (or fix the problem).

Comment 3 Ulrich Drepper 2003-10-03 09:10:53 UTC
Closing since I got no reply.


Note You need to log in before you can comment on or make changes to this bug.