Bug 177890 - GiveConsole creates wrong entries for ":0" in utmp
GiveConsole creates wrong entries for ":0" in utmp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC6Target FC4Update FC5Update FC6Desktop
  Show dependency treegraph
 
Reported: 2006-01-16 02:13 EST by Wilfried Teiken
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-24 04:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wilfried Teiken 2006-01-16 02:13:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
When GiveConsole is executed the utmp entry created via sessreg gets the pid of the GiveConsole process. As the pid is invalid when GiveConsole terminates these entries are not displayed by who, last, ... by default.



Version-Release number of selected component (if applicable):
xorg-x11-xdm-6.8.2-37.FC4.49.2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:

A fix is:
--- GiveConsole 2006/01/16 06:06:15     1.1
+++ GiveConsole 2006/01/16 06:06:24
@@ -8,5 +8,5 @@
 # causing serious grief.
 #
 chown $USER /dev/console
-/usr/X11R6/bin/sessreg  -a -w "/var/log/wtmp" -u "/var/run/utmp" \
+exec /usr/X11R6/bin/sessreg  -a -w "/var/log/wtmp" -u "/var/run/utmp" \
        -x "/etc/X11/xdm/Xservers" -l $DISPLAY -h "" $USER
Comment 1 Mike A. Harris 2006-02-01 19:01:21 EST
This is an automated note being applied to multiple bugs simultaneously
intended to provide some useful general information.  Please do not reply.

General info for Fedora bug reporters:  Please note that all Fedora Core 4
bugs being filed against any part of the X Window System, should be filed
against the "xorg-x11" bug component.  Bugzilla components correspond to the
src.rpm package from which any application or particular file has been built
from.  "xorg-x11" is the single src.rpm in FC4 which fully contains the
X window system.

All of the other xorg-x11-* components listed in bugzilla, such as xorg-x11-xdm,
xorg-x11-drv-*, and various other components, are those which are part of the
current Fedora Core 5 development process, and are intended only for bugs
being filed against FC5 test releases and "rawhide" which contain the X11R7
release of the X Window system.

When filing FC4 bugs, please ensure you are using "xorg-x11" as a component
and not one of the FC5/devel related components.  This may seem a bit
confusing, since bugzilla presents all of these components as choices
even for FC4.

This seems to be an unfortunate limitation in bugzilla, which does not
appear to be able to restrict individual components to a single product
version, thereby every component in every version appears in the list
for all versions.

When we find a bug filed against a component that is not included in that
particular OS release, we'll do our best to ensure it gets reassigned to
the correct component, however any help users can provide by filing
against the right component, or reassigning misfiled bugs they spot
to the right component would be greatly appreciated.

Thanks in advance, and apologies for any inconveniences.
Comment 3 Matthias Clasen 2006-07-06 17:50:54 EDT
Add to FC6Destop tracker
Comment 4 Mike A. Harris 2006-07-24 04:13:00 EDT
Fixed in xorg-x11-xdm-1.0.5-5.fc6

Note You need to log in before you can comment on or make changes to this bug.