Bug 177896 - no output from multipath with qla2312 hba
no output from multipath with qla2312 hba
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Marzinski
Depends On:
  Show dependency treegraph
Reported: 2006-01-16 04:52 EST by Stephan Ebelt
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version: 0.4.5-12.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-15 16:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
strace output of 'multipath -v4' (4.35 KB, text/plain)
2006-02-15 07:36 EST, Stephan Ebelt
no flags Details

  None (edit)
Description Stephan Ebelt 2006-01-16 04:52:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
multipathing doesn't work at all on my system and I have no glue why: I can't get multipath to show a single line of output - not even the complain when the dm_multipath module is not loaded.

kernel: kernel-smp-2.6.14-1.1656_FC4
HBA:    qla2312, one Volume assigned in the SAN and present as sdb and sdc on the 
        Host, please see below.

Qlogic FC Driver: 8.01.00-k

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot system
2. make sure dm_multipath and other dm modules are loaded
3. run multipath -v4 -d
4. or run multipath -v2 -l
5. or run multipath -v10
6. or run multipath -<any other option>

Actual Results:  nothing happens.

Expected Results:  multipath should display some sort of status information. I.e. the devices it detected, which ones are blacklisted, ... etc. Depending on the given options. Just anyhing that is more than 'nothing'. ;-)

Ideally it should assemble a device named by WWID in /dev/mapper.

Additional info:

disks are present i.e. in /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: LSILOGIC Model: 1030 IM       IM Rev: 1000
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: IBM      Model: 1722-600         Rev: 0520
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: IBM      Model: 1722-600         Rev: 0520
  Type:   Direct-Access                    ANSI SCSI revision: 03

the first device (LSILOGIC) is the internal disk. The two other disks (IBM 1722-600) are one SAN volume seen twice through the two QLA2312 HBAs.
Comment 1 Stephan Ebelt 2006-01-16 05:02:26 EST
one more thing: I tried with and without the /etc/multipath.conf file. The one I
have used was gathered from a RHEL4 System on the very same SAN, where multipath
works fine. It's only purpose is actually to blacklist the internal disk (sda): 

devnode_blacklist {
        wwid 26353900f02796769
        devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
        devnode "^hd[a-z][[0-9]*]"
        devnode "^cciss!c[0-9]d[0-9]*[p[0-9]*]"

        # the internal disk
        devnode "^sda"

multipaths {
        multipath {
                wwid    3600a0b800017cc2400001b6d43beb16a
                alias   fc101

BTW: why is no default multipath.conf file included in FC4? There should be a
rough skeleton file to quickly setup aliases. Or did I miss something here?
Comment 2 Stephan Ebelt 2006-02-15 07:34:35 EST
ok, I just upgraded to kernel 2.6.15-1.1831_FC4smp (plus all other available FC
patches) and tried the same thing again.

I still can not get multipath to output anything. I have attached the strace
output of 'multipath -v4'. It doesn't tell me much. All I can see is that it 
seems to exit right after /etc/multipath.conf was read.
Comment 3 Stephan Ebelt 2006-02-15 07:36:12 EST
Created attachment 124673 [details]
strace output of 'multipath -v4'
Comment 4 Ben Marzinski 2006-09-15 16:46:48 EDT
This problem is fixed in fc5

Note You need to log in before you can comment on or make changes to this bug.