Bug 1779025 - Pantheon cannot install because wingpanel-indicator-datetime is missing the libecal dependency
Summary: Pantheon cannot install because wingpanel-indicator-datetime is missing the l...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wingpanel-indicator-datetime
Version: 31
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Fabio Valentini
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-03 05:08 UTC by Justin
Modified: 2019-12-17 01:44 UTC (History)
2 users (show)

Fixed In Version: wingpanel-indicator-datetime-2.2.1-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-17 01:44:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Justin 2019-12-03 05:08:16 UTC
Description of problem:

Wingpanel (thus pantheon) cannot install because of a missing dependency.


Version-Release number of selected component (if applicable):

wingpanel-indicator-datetime-2.1.3-3.fc30.x86_64

How reproducible: Always.

Steps to Reproduce:
1. # dnf group install 'pantheon desktop'
or
1. # dnf install wingpanel-indicator-datetime

Actual results:

Last metadata expiration check: 2:10:11 ago on Mon 02 Dec 2019 09:48:23 PM EST.
Error: 
 Problem: conflicting requests
  - nothing provides libecal-1.2.so.19()(64bit) needed by wingpanel-indicator-datetime-2.1.3-3.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)


Expected results: Wingpanel should install.

Additional info: libecal is not in the repos.

Comment 1 Fabio Valentini 2019-12-03 11:12:52 UTC
I'm sorry you're having issues with Pantheon on fedora 31. I'm aware of this issue and I basically can't do anything about it, since the upstream project for the Date & Time indicator doesn't support the version of libecal (evolution-data-server) that's available on fedora 31:

https://github.com/elementary/wingpanel-indicator-datetime/issues/122
https://bugzilla.redhat.com/show_bug.cgi?id=1705553
https://bugzilla.redhat.com/show_bug.cgi?id=1736968

Porting the code from libecal-1.2 to libecal-2.0 doesn't seem to be trivial, so I can't do it myself.


You can work around this issue by installing everything *but* wingpanel-indicator-datetime - provided you don't mind that the top panel is not displaying the time.

Comment 2 Fedora Update System 2019-12-07 21:35:24 UTC
FEDORA-2019-886409cae5 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-886409cae5

Comment 3 Fabio Valentini 2019-12-07 21:49:08 UTC
I was able to build a fedora update that includes the support for libecal-2.0, which was published just yesterday.
With this update, there should be no dependency issues left.

Comment 4 Fedora Update System 2019-12-08 01:46:50 UTC
wingpanel-indicator-datetime-2.2.1-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-886409cae5

Comment 5 Fedora Update System 2019-12-17 01:44:49 UTC
wingpanel-indicator-datetime-2.2.1-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.