Bug 1779034 - FreeCAD hangs loading a specific CAD Model
Summary: FreeCAD hangs loading a specific CAD Model
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1784153
TreeView+ depends on / blocked
 
Reported: 2019-12-03 06:00 UTC by Andrig Miller
Modified: 2020-01-05 00:40 UTC (History)
3 users (show)

Fixed In Version: freecad-0.18.4-3.fc30 freecad-0.18.4-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-04 22:14:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrig Miller 2019-12-03 06:00:55 UTC
Description of problem:

FreeCAD hangs when loading a particular CAD model (all other of my models work).


Version-Release number of selected component (if applicable):


How reproducible:

Everytime


Steps to Reproduce:
1. Open 180mmBoreCenterBlock.FCstd
2. UI says 100% loaded, but hangs.
3. Eventually, you get a message in GNOME that says unable to lock/blocked by an application, and FreeCAD has to be killed.

Actual results:

FreeCAD hangs, and has to be killed.

Expected results:

FreeCAD should render the model, and be ready to edit.


Additional info:

Link to the model, since its too big to attach:

https://www.dropbox.com/s/d8jppvlk77dpnwu/180mmBoreCenterBlock.FCStd?dl=0

Comment 1 Richard Shaw 2019-12-03 15:51:08 UTC
Not to rehash the whole history of FreeCAD problems on Fedora :)

It's not in a good state and to make matters worse I only have FreeCAD working with Coin4 in Rawhide due to the major update policy. The best bet for now (but no guarantees) is to use my COPR:

https://copr.fedorainfracloud.org/coprs/hobbes1069/FreeCAD_NEXT/

Comment 2 Andrig Miller 2019-12-04 04:21:58 UTC
I am on the latest update that was pushed to the updates repo, and it's a later version of what is in your COPR repository.

Comment 3 Richard Shaw 2019-12-04 14:21:49 UTC
Yup, forgot to bump that. I think I may bump the Epoch on the COPR package to something ridiculously large so if the COPR is enabled you always get the FreeCAD package from it instead of the main repo...

Comment 4 Richard Shaw 2019-12-06 17:28:35 UTC
New builds in the COPR are starting to complete. I have bumped the Epoch to 99 so if/when the real Fedora builds are fixed you'll have to manually remove the package first.

Comment 5 Andrig Miller 2019-12-09 02:48:48 UTC
I get the following after installing the COPR packages:

[andrigtmiller@worklaptop ~]$ FreeCAD
FreeCAD 0.18, Libs: 0.18RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Sheet Metal workbench loaded
FreeCAD: /builddir/build/BUILD/FreeCAD-0.18.4/src/Mod/Part/Gui/TaskDimension.cpp:1199: static void PartGui::ArcEngine::initClass(): Assertion `SoEngine::getClassTypeId() != SoType::badType()' failed.
Aborted (core dumped)

Comment 6 Fedora Update System 2019-12-18 01:25:32 UTC
Coin4-4.0.0-4.fc31, freecad-0.18.4-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e935331fe6

Comment 7 Fedora Update System 2019-12-18 02:08:46 UTC
Coin4-4.0.0-4.fc30, freecad-0.18.4-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3d88bddf00

Comment 8 Fedora Update System 2019-12-18 09:58:28 UTC
FEDORA-2019-3d88bddf00 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3d88bddf00

Comment 9 Fedora Update System 2019-12-18 09:58:30 UTC
FEDORA-2019-e935331fe6 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e935331fe6

Comment 10 Fedora Update System 2020-01-04 22:14:56 UTC
Coin4-4.0.0-4.fc30, freecad-0.18.4-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2020-01-05 00:40:15 UTC
Coin4-4.0.0-4.fc31, freecad-0.18.4-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.