Bug 1779076 - WithDashboardResources HOC has incorrect comparison for alerts results
Summary: WithDashboardResources HOC has incorrect comparison for alerts results
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1781053 1781055
TreeView+ depends on / blocked
 
Reported: 2019-12-03 08:53 UTC by Rastislav Wagner
Modified: 2020-05-13 21:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The comparison of new and previous alerts was not correct. Consequence: Status card in Dashboards page may rerender frequently causing performance issues. Fix: Fixed the new/previous comparison logic. Result: Status card is rerendered only when alerts actually changed.
Clone Of:
: 1781053 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:53:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2805 0 None closed Update dashboard redux state format 2020-05-04 06:33:48 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:53:41 UTC

Description Rastislav Wagner 2019-12-03 08:53:45 UTC
Description of problem:
shouldComponentUpdate of WithDashboardResources HOC should compare old results of alerts vs new ones but it actually compares new alerts vs old prometheus results which is never true. In case a component watches alerts, this may cause performance problems due to unnecessary rerenders.

The issue is already fixed in 4.3 by https://github.com/openshift/console/pull/2805

Comment 2 Radim Hrazdil 2019-12-09 08:25:47 UTC
Verified

Comment 4 errata-xmlrpc 2020-05-13 21:53:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.