Bug 1779116 - VM created from VM Template doesn't clone DVs from the template
Summary: VM created from VM Template doesn't clone DVs from the template
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Filip Krepinsky
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-03 10:52 UTC by Radim Hrazdil
Modified: 2020-05-13 21:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Datavolumes for URL sources were not created on template creation Fix and Result: Datavolumes are created on template creation. Also a warning in wizard's disk modal is shown that such creation will occur. VM created from such template will clone template's PVC
Clone Of:
Environment:
Last Closed: 2020-05-13 21:53:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3665 0 'None' closed Bug 1779116: vm template should create url import dataVolumes on its creation 2020-04-20 12:16:25 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:53:43 UTC

Description Radim Hrazdil 2019-12-03 10:52:03 UTC
Description of problem:
When a user creates a VM from a Template, which has for example a rootDisk created from a URL source, the VM rootdisk copies the same source configuration, meaning that it's source is the same URL, instead of cloning the existing datavolume.


Version-Release number of selected component (if applicable):
4.3

How reproducible:
100%

Steps to Reproduce:
1. Create a VM template via Wizard and select URL provision method
   Use for example https://download.cirros-cloud.net/0.4.0/cirros-0.4.0-x86_64-disk.img
2. Create a VM from the template
3. Inspect the VM DataVolume

Actual results:
The VM datavolume source also points to the URL 

Expected results:
The VM datavolume source should point to the TM Template PVC and should be cloned

Additional info:

Comment 2 Guohua Ouyang 2020-02-20 07:17:49 UTC
verified on 4.4.0-0.nightly-2020-02-17-022408

Comment 4 errata-xmlrpc 2020-05-13 21:53:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.