Bug 1779201 - Knative revision should have connectors in topology
Summary: Knative revision should have connectors in topology
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-03 13:58 UTC by Karthik Jeeyar
Modified: 2020-05-13 21:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Cause: Knative service/reivision is not having any connectors to connect to other workloads Consequence: There is no way to add the connection between knative workloads to other workloads Fix: Added a connector from the revision( which is later on changed to knative service), so that knative workloads can connect to other workloads Result: Move the connector knative workload to other workloads.
Clone Of: 1779191
Environment:
Last Closed: 2020-05-13 21:53:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
There are connectors for Knative revisions (156.11 KB, image/png)
2020-03-03 11:11 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3646 0 'None' closed Bug 1779201: fix(knative-connectors): add connectors to knative revision in topology 2020-04-20 09:16:43 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:53:46 UTC

Description Karthik Jeeyar 2019-12-03 13:58:54 UTC
+++ This bug was initially created as a clone of Bug #1779191 +++

Description of problem:

Service Binding request should be supported between a revision (its deployment) and an operator backed service and also need support for a visual connector between the revision and another workload.


Steps to Reproduce:
1. hover on the knative revision in the topology, a binding/visual connectors are not appearing.

Actual results:

No connectors for knative revisions.

Expected results:

As a user, I want to connect the knative revision with operator backed services(database), but the draggable blue connectors are not showing up on hovering the knative revision.

Comment 2 Gajanan More 2020-03-03 11:10:34 UTC
I have validated this on 
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108
Marking this bug as verified

Comment 3 Gajanan More 2020-03-03 11:11:24 UTC
Created attachment 1667158 [details]
There are connectors for Knative revisions

Comment 5 errata-xmlrpc 2020-05-13 21:53:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.