Bug 1779263 - During upgrade encryption operator throws errors due to missing revision on pods
Summary: During upgrade encryption operator throws errors due to missing revision on pods
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1779237
TreeView+ depends on / blocked
 
Reported: 2019-12-03 15:41 UTC by Stefan Schimanski
Modified: 2020-05-13 21:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1779237
Environment:
Last Closed: 2020-05-13 21:53:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-openshift-apiserver-operator pull 271 0 'None' closed Bug 1779263: bump(library-go): encryption: cope with missing revisions on upgrade 2020-03-25 11:24:26 UTC
Github openshift library-go pull 624 0 'None' closed Bug 1779263: encryption: cope with missing revisions on upgrade 2020-03-25 11:24:27 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:53:49 UTC

Comment 2 Xingxing Xia 2020-01-09 09:25:51 UTC
As per bug 1779237#c4, the cause is OAS 4.2 pods don't have "revision" label. OAS 4.3 pods do. So the issue is not an issue in 4.3 to 4.4 upgrade. Two bugs were created just for the latest-to-former backport process. So changing Status ...

Comment 4 errata-xmlrpc 2020-05-13 21:53:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.