Bug 1779340 - [Feature:Marketplace] Marketplace resources with labels provider displayName test fails frequently
Summary: [Feature:Marketplace] Marketplace resources with labels provider displayName ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.0
Assignee: Nick Hale
QA Contact: Fan Jia
URL:
Whiteboard:
: 1780143 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-03 19:12 UTC by Adam Kaplan
Modified: 2020-05-04 11:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:18:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24252 0 'None' closed Bug 1779340: test(marketplace): poll for packagemanifests 2020-10-07 15:22:23 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:18:49 UTC

Description Adam Kaplan 2019-12-03 19:12:15 UTC
Description of problem:

Test "[Feature:Marketplace] Marketplace resources with labels provider displayName [ocp-21728]create opsrc with labels [Suite:openshift/conformance/parallel]" is the current top flake for 4.4 on all public clouds (AWS, GCP, and Azure). It is preventing merges in origin.

Version-Release number of selected component (if applicable): 4.4.0-latest

How reproducible: Frequently

Additional info:

1. AWS - https://k8s-testgrid.appspot.com/redhat-openshift-ocp-release-4.4-informing#release-openshift-ocp-installer-e2e-aws-4.4
2. GCP - https://k8s-testgrid.appspot.com/redhat-openshift-ocp-release-4.4-informing#release-openshift-ocp-installer-e2e-gcp-4.4
3. Azure - https://k8s-testgrid.appspot.com/redhat-openshift-ocp-release-4.4-informing#release-openshift-ocp-installer-e2e-azure-4.4

Comment 3 Jeff Peeler 2019-12-06 18:41:54 UTC
*** Bug 1780143 has been marked as a duplicate of this bug. ***

Comment 5 Fan Jia 2019-12-16 09:16:42 UTC
Add the wait time for "oc get packagemanifest" and the problem won't happen again.

Comment 7 errata-xmlrpc 2020-05-04 11:18:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.