Bug 177952 - Error during build of kbibtex
Error during build of kbibtex
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kbibtex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christian Nolte
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 14:28 EST by Jochen Schmitt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 11:16:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2006-01-16 14:28:33 EST
Description of problem:

Build of kbibtex from cvs failed.

Version-Release number of selected component (if applicable):

KDE 3.5, Fedora Core 4

How reproducible:

cvs co kbibtex
cd kbibtex/devel
make i686

Actual results:


/usr/lib/qt-3.3/include/private/qucomextra_p.h:65: warning: 'struct
QUType_QVariant' has virtual functions but non-virtual destructor
/usr/lib/qt-3.3/include/private/qucomextra_p.h:87: warning: 'struct
QUType_varptr' has virtual functions but non-virtual destructor
/bin/sh ../libtool --silent --mode=link --tag=CXX g++  -Wnon-virtual-dtor
-Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align
-Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG
-DNO_DEBUG -O2 -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32
-march=i686 -mtune=pentium4 -fasynchronous-unwind-tables -Wformat-security
-Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common    -o
kbibtex -L/usr/X11R6/lib -L/usr/lib/qt-3.3/lib -L/usr/lib  main.o kbibtex.o -lkparts
grep: /lib/libattr.la: No such file or directory
/bin/sed: can't read /lib/libattr.la: No such file or directory
libtool: link: `/lib/libattr.la' is not a valid libtool archive
make[3]: *** [libkbibtexpart.la] Error 1
make[3]: Leaving directory
`/home/pclinux/cvs/fed-extras/kbibtex/devel/kbibtex-0.1.3/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/home/pclinux/cvs/fed-extras/kbibtex/devel/kbibtex-0.1.3'
make[1]: *** [all] Error 2
make[1]: Leaving directory
`/home/pclinux/cvs/fed-extras/kbibtex/devel/kbibtex-0.1.3'
Fehler: Bad exit status from /var/tmp/rpm-tmp.32643 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.32643 (%build)
make: *** [i686] Fehler 1


Expected results:

Creation of the RPM file.

Best Regards:

Jochen Schmitt
Comment 1 Christian Nolte 2006-01-16 15:50:51 EST
That's odd, I cannot reproduce this problem. Could you please verify the status
of the libattr-packages on your system with 'rpm -q libattr libattr-devel'?
Comment 2 Jochen Schmitt 2006-01-17 10:53:32 EST
I had libattr 2.4.1-2 installed. I have make a update to 2.4.24-1.FC4.1, but the
same error still occured.

Best Regards:

Jochen Schmitt
Comment 3 Jochen Schmitt 2006-01-17 11:16:21 EST
Hello,

after further axamination I have to found out, that the problem was coused by a
file called 'libacl.la', which contains a reference to the unavailable file
'/lib/libattr.la'.

after I have updated libacl to the most current version 2.2.32, the build worked
fine.

Best Regards:

Jochen Schmitt

Note You need to log in before you can comment on or make changes to this bug.